PDA

View Full Version : ISScript9.msi > ISScript11.msi



Robert Smith
08-05-2005, 01:55 PM
I have converted an InstallShield 9 project to an InstallShield 11 project but now when I build via standalone, it includes the ISScript9.msi instead of the ISScript11.msi, but when I build via the InstallShield GUI, it outputs the correct .msi...

I can't seem to find where it is dictated which one to pull into the project.

Anyone have any thoughts on this?

Thanks,

Robert

MichaelU
08-05-2005, 05:19 PM
I think this is dictated by the version of the builder, not a setting in the project. Have you installed the version 11 Standalone Build, or are you using the one from version 9 you had installed previously?

Robert Smith
08-08-2005, 12:05 PM
Have you installed the version 11 Standalone Build, or are you using the one from version 9 you had installed previously?

Yes, I have the Installshield 11 StandaloneBuild installed, and the isscript11.msi is in that path, but it still picks up the isshield9.msi when I build by command line. This occurs for both this converted project as well as a new project that started it's life as an InstallShield 11 project. Both build fine with the GUI and output the ISScript11.msi as part of the build product.

~Robert

Robert Smith
08-08-2005, 12:44 PM
Okay, my fault...had a residual environment variable that was allowing the version 9 standalone to be called instead of the version 11, so am now calling it explicitly so it works fine. Sorry for the thrashing around...