PDA

View Full Version : Installshield 11 useless when upgrading from 10.5 or Express 5



chodgkins
07-15-2005, 05:13 PM
I am totally frustrated with IS11. Twice now I have tried to upgrade projects from previous versions of IS. When I updated an Express 5 project and added some new files to a subdirectory to the INSTALLDIR I would periodically lose the whole directory. If I re-created the directory, it would return.

The update from a 10.5 project was OK but when I generated a new release it proceeded to build OK until it started to generate the CAB file. It never finished. When I checked the resouces used in Task Manager, it was using between 97-99% and this is on a machine with 1GB of memory!

On top of all that, now that Macrovision has taken over, I can't use my Installshield support logon, I need to get a new logon from Macrovision. :mad: I've applied for a new logon, but I haven't received a reply and probably won't get one today it being about 3pm Pacific time.

Why does it seem that every release of IS get more and more bulky and slow?

I'll probably re-install 10.5 just to get this install out the door!

chodgkins
07-15-2005, 05:51 PM
I decided to try one more time on building an install based on a 10.5 project that was upgraded to 11. After building the CAB file for what seemed about twice as long as under 10.5, it finished building the install. So I ran the install and I get a Internal Error 2705, Directory error.

chodgkins
07-18-2005, 11:32 AM
I fixed the 2705 error. It was caused by the project conversion process setting the Directory Parent of DATABASEDIR to ARPAUTHORIZEDCDFPREFIX which is not defined anywhere. I reset it to INSTALLDIR.

Now I get the following errors:

Validating against darice.cub...
ISDEV : warning ICE17: ListBox: 'IS_SQLSERVER_LIST' for Control: 'lstSQLServer' of Dialog: 'SQLBrowse' not found in ListBox table. Control Property SQLBrowse lstSQLServer
ISDEV : warning ICE17: ComboBox: 'IS_SQLSERVER_SERVER' for Control: 'cboServers' of Dialog: 'SQLLogin' not found in ComboBox table. Control Property SQLLogin cboServers
ISDEV : error ICE18: KeyPath for Component: 'ISX_DEFAULTCOMPONENT6' is Directory: 'FontsFolder'. The Directory/Component pair must be listed in the CreateFolders table. Component Directory_ ISX_DEFAULTCOMPONENT6
Completed validation against darice.cub


I also still do not have a valid login to support despite a valid support contract and having applied for the Macrovision support signup on Friday. :(

bwallan
08-03-2005, 01:55 AM
I have received the following message on build (using InstallShield 11 Express):

ISEXP : error -6262: The directory table contains the entry ARPAUTHORIZEDCDFPREFIX. This identifier is reserved ; defining it in the directory table will yield unpredictable results at runtime. Use the Direct Editor to rename this directory Identifier.

What is Direct Editor and how do I access it?

Also, any idea what ARPAUTHORIZEDCDFPREFIX is? Or what a directory table is? Never saw this in the working Express 3.5.4 build?

Running Windows XP Professional w/o SP2. We cannot get SP2 and our communications operational at same time; communications more important!

You mentioned changing the InstallDir? Did it show ARPAUTHORIZEDCDFPREFIX or did you just try changing it?

You're a lot frustrated with InstallShield 11. I'm a lot frustrated with the Express version. I was hoping it would resolve some of the problems I've encountered in 3.5.4 Express. Instead it has given me more problems to resolve!!?? Appear to be going the wrong direction with installers?

Also, no one appears to be the least bit interested in answering questions posted to the InstallShield 11 Express board. I'm assuming problems with InstallShield 11 are pretty much common across releases...

Thanks for assistance.

chodgkins
08-08-2005, 12:00 PM
The Direct Editor is a function of the Professional version of IS. So unless you can find someone with that version, you will have to look at something like ORCA which is available from Microsoft as part of their Windows SDK.

I have no real idea what ARPAUTOORIZEDCDPREFIX is but since I have the Pro version, I can change it to something meaningfull like INSTALLDIR.

Yes I am frustrated with Installshield. I have paid support and have used it but although they have given me solutions, it involves going through my project after it has been converted and editing a LOT of entries. Since I have quite a few installs to update, this means that I have to spend 1-2 hours per install to fix their buggy conversion routines! NOT ACCEPTABLE!

So I have down graded to 10.5 Pro which is what I had been using to create installs and will not upgrade further unless forced to by changes in the MS installer.

I think that a large part of the issues we are facing are, in part, due to Microsoft's installer requirements but also Installshield seems to have done a poor job of handling users who are converting install projects from previous versions of Installshield and I do not think that the purchase by Macrovision will recify these problems.

I wish that I could help more, but my experience of using IS Express has been that the only solution is to completely rebuild from scratch. This is why we decided to upgrade to IS Pro starting with version 9.

Charles

nitsev
08-09-2005, 07:01 AM
cut from the InstallShield website. I assume it applies to version 11 as well.

"I have an older installation project from a different InstallShield solution. Can I easily migrate it to InstallShield X?

Software developers working on installations have enough to worry about without the hassles of migrating from one install to another. That’s why InstallShield offers the Migration Guarantee for InstallShield X. Now, when you open your InstallShield DevStudio 9, InstallShield MultiPlatform 5, InstallShield Professional 6.x or 7, InstallShield Developer 7 or 8, or InstallShield Windows Installer projects in InstallShield X, your installation automatically migrates to InstallShield X. If it doesn’t, InstallShield’s senior support engineers will fix it for you at no cost. GUARANTEED!"

ShaneMacL
08-10-2005, 05:36 AM
I have just installed IS Express 11 and tried to open my existing Express 3 projects. The software tells me it is going to perform the update, renames the old file, refreshes the classes, and hangs trying to refresh the objects. I have tried this on a number of projects and it is the same with all of them. Anyone out there got this to work?