PDA

View Full Version : Custom Actions out of sequence after upgrade from X express



johnd2
07-11-2005, 07:15 AM
Hello all,

Having just upgraded my install project from X Express to 11 professional it seems that a number of my custom actions are no longer run. The text "absent from sequence" is shown in all the sequencing fields.

What are the equivalent sequence points for custom actions that, in X Express, would have been run:

"After Initialization"
"After Customer Information Dialog"
"After Setup Type dialog"
"After Setup Progress dialog"
"After File Transfer"
"After Setup Complete Success dialog"

and (on uninstall)

"After System Changes".

Thanks,

John

RobertDickau
07-11-2005, 07:23 PM
If you have an MSI database that you built with your Express project, you can open it with InstallShield 11 and view the placement and settings for the actions there...

johnd2
07-12-2005, 04:19 AM
Hi Robert,

Thanks for the response.

I've tried loading the MSI file in 11, and the result is the same. It seems that although all of the custom actions are executed not all of them appear in the "Behavior and Logic->Sequences" section.

On the one hand the installation works (well nearly - see thread about "caExtractIISSuppFiles"), on the other it is difficult for me to understand and modify the installation with this custom action problem.

/john

MichaelU
07-12-2005, 10:37 AM
Several of those actions listed as "after ... dialog" are probably tied to dialog behavior instead of to install sequences. You might have better luck finding these as DoAction events on the corresponding dialogs.

johnd2
07-12-2005, 10:47 AM
Hi Michael,

Thanks, that was exactly right. The custom actions were associated with the "Next" button on each of the dialogs.

Would be nice if that information was listed along with the custom action. I think I've been spoiled with the much easier to use Express.

Thanks again,

John.