PDA

View Full Version : 1607: unable to install installshield scripting runtime.



inneed_ofhelp!!
07-05-2005, 11:57 AM
Hi all,

hoping some of you here can help me out...

i've recently tried installing 'itunes' but towards the end of the installation setup i get this error msg:

1607: unable to install installshield scripting runtime.

i've found that my computer opens up .msi files with notepad! is this normal or is there some kind of configuration confilct which is perhaps becoming an issue here??

any help on this would be great as tbh its a right pain in the rectum!

i'm using window 2000 pro, pretty sure its all up to date with the resources i'd need but for some reason i cant get it to work..

is there not a way i can jst re-install installshield?? it appears to be alot tougher than i 1st thought!

cheers all

Ben :confused:

inneed_ofhelp!!
07-06-2005, 09:07 AM
common guys!! I thought coming onto a forum primarilly regarding 'installshield' i'd have a few people who'd beable to help me out on this one seeing as it is the installshield that seems to be cocking up!

any ideas guys?? really want to try and get this fixed, its such a pain!

cheers again!

Stefan Krueger
07-06-2005, 10:19 AM
I think we are just tired of answering the same questions over and over again :)

Try if this article helps:
http://consumer.installshield.com/kb.asp?id=Q108340

Next, search this forum for replies to similar questions (a quick test resulted in more than 50 threads)

inneed_ofhelp!!
07-11-2005, 05:53 AM
I think we are just tired of answering the same questions over and over again :)

Try if this article helps:
http://consumer.installshield.com/kb.asp?id=Q108340

Next, search this forum for replies to similar questions (a quick test resulted in more than 50 threads)


apologies if this has been asked before, i did try searching on here but was unsuccessful, have found that site you posted (thanks btw) but it hasn't helped me..

as said, is there no easy way to jst re-install installshield as i think some of the files may have become corrupt!??

cheers

inneed_ofhelp!!
07-12-2005, 07:10 AM
someone must know if there is a replacement download of installshield?? common guys!

can someone plz post up a link for a download so i can sort out this annoying, persistant problem!

if there isnt an easy 'fix' what else can i do abt it??
thanks

Stefan Krueger
07-13-2005, 08:38 AM
I don't think there's such a thing as a "replacement download of installshield". Did you look at all the other threads about this topic? If one of these was able to help you then I don't think anyone here can.

inneed_ofhelp!!
07-13-2005, 09:14 AM
believe me i've tried all the 'fixs' i have come across..

in the registry, i believe:

HKEY_LOCAL_MACHINE>SOFTWARE>INSTALLSHIELD

should be found but in mine it doesnt exist... also in 'C:\Program Files\Common Files\InstallShield' i only have 2 folders:

'engine' and 'IScript' but when i come to trouble-shooting i often come across a folder that should be called 'Idrivers'?? which i cant access if i dont have.

that's why i'm asking if there is some kind of 're-install' or update as it seems some of my files are either corrupt or deleted completely.

thanks

Christopher Painter
07-13-2005, 11:36 AM
common guys!! I thought coming onto a forum primarilly regarding 'installshield' i'd have a few people who'd beable to help me out on this one seeing as it is the installshield that seems to be cocking up!

any ideas guys?? really want to try and get this fixed, its such a pain!

cheers again!

I've seen this posted over and over and the bottom line is this is a forum for installation developers, not end user support. There was even a thread from IS Support saying they were calling Apple to discuss providing ( selling ) them resources to help with their installs since we get so many support requests over here. I think I even remember seeing a post on Monster.com for an InstallShield contractor working for Apple.

inneed_ofhelp!!
07-14-2005, 05:44 AM
ok, point taken but surely there is something you guys can direct me towards to be able to get rid of this 1607 error?

is there not a download for a generic basic version of installshield?? otherwise it looks like im going to have to format my HD jst to try and get round this installation problem.

ive managed to rename the .dll files so that i can re-install 'InstMsiW.exe' which works fine, but then i try to install 'ISScript8.msi' (which does run now as before it jst opened in notepad), and i get another windows installer error.. see pics jst below..

any idea at all what the best solution for this prob i've got??


http://img.photobucket.com/albums/v351/piggyot306/Random/win_installer_scn.jpg
http://img.photobucket.com/albums/v351/piggyot306/Random/win_installer_scn1.jpg

Christopher Painter
07-14-2005, 07:13 AM
I can only tell you that MSI errors 1601, 1603 and 1607 are very generic, they can be caused by literally dozens of reasons. I just updated 1000 machines last night using SMS 2003 and I had about 10 machines that had one of these errors. All 10 machines had something different wrong about them. Same error # doesn't mean same problem.

Run your install with the command line:

setup /v"/l*v c:\msi.log" and post the logfile. You can also try reinstalling your MSI runtime. There are articles here and MS Support KB that explain how.

inneed_ofhelp!!
07-14-2005, 07:58 AM
ok thanks mr painter..

how do i run the install with 'setup /v"/l*v c:\msi.log'??

chucked it in 'run' but that jst brings up a 'windows 2000 set up' screen.

dont mean to sound ignorant, jst really dont know too much about all this! :rolleyes:

something seems to be stopping the .msi files running tho when executed, weird. hope you can help some more! :o

inneed_ofhelp!!
07-15-2005, 10:14 AM
mr painter?? anyone?? 750 views at this thread yet no1 is willing to lend a hand! all responces are much appreciated! :o :rolleyes:

thanared
09-14-2005, 02:51 PM
i had this same problem at work.. we had spotty internet connectivity.. and my IT admin didnt know how to run a proper dns server

well since his dns server was so spotty.. i decided to use another dns server rahter than him

i changed my dns server to 151.164.11.201.. (that made my internet run considerably faster)

after this itunes install worked..

i know this is completely out of the way.. but i am just giving you info that worked for me...

i could only guess that eitehr it was coincidental or maybe itunes calls a server to see if there are any updates to itunes available ath the beginning of the install

oliviald
09-20-2005, 06:27 PM
I had the same exact problem. I also tried the page link found in google (same site provided by Stefan Krueger) and it didn't work. Most of the links/tabs in the procedure didn't exist on my computer.

I tried the following and it worked:

Register the IDriver file manually on the machine. To do this, click Start->Run and paste the following command into the Open box and click OK:

"C:\Program Files\Common Files\InstallShield\Driver\7\Intel 32\IDriver.exe" /REGSERVER

:)

bmvl81
10-24-2005, 10:25 PM
Make sure the Window Install service is running on your machine.

GO:
Start, run, type: services.msc

Scroll down to: Windows Installer
If this is disabled, right click, select properties, change startup type to automatic. and go ahead and start the service, continue with your install.

If this does not solve your problem, continue trying other suggestions.

Christopher Painter
10-24-2005, 10:39 PM
1603 and 1607 error messages have many possible causes. There is no one size fits all solution.

da_straz
11-08-2005, 12:47 AM
I tried restarting my computer, and that fixed the problem!! Have you tried that??

For all who have this problem and wish to fix it:

RESTART YOUR COMPUTER

It may work, saving you loads of hassle

PS. If there are so many people with this problem, shouldn't the installshield people be at leasty attempting to fix it??

da_straz
11-08-2005, 12:49 AM
Oh yeah, so that no-one gets angry that my advice didn't work, I'll say this:

IT MAY NOT WORK (but it's worth a try)