View Full Version : IIS Site Created but won't Start

06-30-2005, 07:53 PM

I am having some strange behaviour with the creation of IIS sites. I've started a blank Basic MSI and created a new IIS site with one virtual directory, basically all I changed was the port number and left everything else as is. When I run the install on a W2003 machine the site and virtual dir is created but it's always 'Stopped' and there is no way I can start it. When I try and start the website I get the error 'The parameter is incorrect' and it won't start.

When I do a iisreset and look in the Event Viewer I get the following error -

'The application '/testvd/' belonging to site '6745' has an AppPoolId set, but the property is empty. Therefore, the application will be ignored.'


'The virtual site '6745' has been invalidated and will be ignored because the site's AppPoolId is null.'

I've also tried with an InstallScript Project and the exact same thing happens. I have tried playing around with the Properties in IIS but no matter what I change I can't get the site to Start.

Does anyone know why this is happening??

Thanks, Rick

07-25-2005, 06:25 PM
My apologies for being late with a response, I just saw this post. Are you installing any IIS 6 features (app pools, web extension, etc) with your project? You can check by simply checking the IIS view.

If you are not installing any IIS 6 features, I believe there is a workaround. After the AppSearch action, reset the IIS_VERSION property to 4. IIS 6 features, such as app pools, will not be installed unless the IIS_VERSION is 6.

However, I would still like to investigate this further. I have not reproduced this behavior on my end. So, if you could let me know if you have more information at this point that would be very helpful.

07-26-2005, 11:50 AM
Ok, I found a better workaround:

-Find the website in your project.
-Go to the 'Home Directory' tab
-Change the AppPool dropdown to 'DefaultAppPool'.

The problem is that the AppPool is null. You can pick a different value for the apppool if you wish but it sounds like you are not configuring apppools. This should only affect Windows 2003 Server systems with IIS 6 installed. I submitted a work order for this (WO#IOC-000034607) to avoid the workaround in the future.