PDA

View Full Version : Merge Modules update



mmoore@ntsdata
06-21-2005, 01:08 PM
We have been developing a VFP applicatin using the latest version (6.1.97.82) of MSCOMCTL2.ocx, MSCOMCTL.ocx, etc. When I build my install CD and choses the correct modules, they are at version 6.0.88.xx. Are there any plans to update these items or do I have to do it myself?

TIA

dbriggs
06-24-2005, 10:28 AM
Have you checked who is the author of your existing modules? It could be Microsoft, in which case you could try searching MSDN.

Hope that helps,

David

mmoore@ntsdata
07-20-2005, 02:30 PM
I am still having issues with Merge Modules. Four of them in fact. I need to use the latest version of the OCX 6.1.X.X for comdlg32, mscomct2, mscomctl and mswinsck. However the Merge Modules that I can get from InstallShield are at 6.0.X.X. I tried creating my own merge module, but after I did that, my installer gives me an error 1606 when run. I need the newer version because we are using functionality from those newer versions that do not exists in the previous version? What do I do, I need help asap.

Thanks

dbriggs
07-21-2005, 06:58 AM
A Google search for mscomct2.msm revealed only v6.0 merge modules. As these are created by Microsoft, that would seem to be the best place to look, but I could only find v6.0 modules there as well.

I'm assuming you haven't got them already somewhere, hidden on your v6.1 CD/DVDs perhaps?

What does error 1606 mean? Looking in MSI.CHM, ERROR_UNKNOWN_FEATURE = Feature ID not registered. OK, so what does *that* mean? Or, it's Could not access location xxx. Did you see anything else in your MSI log file?

It is possible to take merge modules apart. It's just not so easy, especially when there are custom actions coming from DLLs in the Binary Table. I suspect these are just regular DLL installers though (without looking).

What did you try to do with the v6.0 MSMs? Maybe you (or DS9) changed something in the merge module that shouldn't have been changed, so some Properties/Conditions are using the original (correct) value but it doesn't exist any more?

When I update the files in our own package merge modules, all I have to do is rebuild them. I only have to make changes if there are new files to add or old ones to take out.

I'm not sure that's any help...

David

mmoore@ntsdata
07-21-2005, 08:11 AM
Is it possile that these 4 ocx files that i have on my computer have been updated through windows update? I really need the version of the OCX files on my system to be installed on the systems that our software is being run.

As for the error 1606 I was receiving, once I removed my version of the merge modules and used the build in ones provided by IS, that error went away. the only time I got the error was when I acutally ran my setup, before it got to the welcome dialog box.

I am going to try and re-create my 4 merge modules again, so they are exactly like the merge modules that are supplied by IS.

Somebody
07-21-2005, 10:18 AM
I believe the versions of the files you are referencing were distributed as part of the Visual Studio SP6 service pack.

dbriggs
07-21-2005, 10:53 AM
I have a Windows XP Professional virtual machine that has almost all available updates. That still contains v6.0.2900.2180 COMDLG32.DLL, v6.0.88.4 MSCOMCT2.OCX, v6.0.88.62 MSCOMCTL.OCX, and v5.1.2600.2180 MSWSOCK.DLL (no MSWINSCK.DLL).

Sorry, I would think the VS SP-6 media is the best place to look.

David

mmoore@ntsdata
07-21-2005, 11:09 AM
i am looking at all the OCX files, and on my machine all those files are version number 6.1.97.82. I have no idea where they came from. I can only think they came from a Windows Update. There are some minor changes in the MSCOMCTL.OCX that if I tried to use 6.0.88.x, my software will not work.

I was able to create new Merge Modules as a Merge Module Project. When I build that project, it creates the new MERGE MODULE file (MSM) and places it in my Merge Module folder. Now, when I build my IS project, build it and run it, I don't get the error 1606 anymore and I have the right version of OCX files in my installer.

My first mistake was trying to create the Merge Module as a direct edit. I was getting all kinds of errors when I tried to validate it after I saved it. I figured I was doing something wrong. I will post here if this solved my problem.

Again, thanks for the help on this matter.

Mark