PDA

View Full Version : Problems with Installer Class aka installutil.exe



SGorman
06-17-2005, 08:38 AM
I'm having to deploy items from the Microsoft Enterprise Library, such as microsoft.practices.enterpriselibrary.common.dll. This item is a .NET assembly with an installer class. I can run installutil.exe at the command line and the file will register just fine. When one runs installutil at the command line it runs in "transaction" mode, I think. This means it runs the /install and /commit actions all at once I think. If I set the .NET Installer Class flag on the component to Yes then my install fails because when it runs installutil it gets errors.
Windows Installer runs installutil in "notransaction" mode. Actually, I've read things that make it sound like WI doesn't actually run installutil, but instead is directly calling functions from the complementary dll - installutillib.dll. As best as I can tell this means that it executes the install in 2 actions - first it runs the /install action, then it separately runs the /commit action. It is the commit action that fails - something about the savedstate file being missing or corrupt.

Has anyone else had any problems with InstallerClass assemblies using the InstallerClass = Yes flag in WI?

To work around this problem I have created a VBScript that uses WshShell.Run to run installutil.exe and I hide the window (if I don't hide it we see an ugly DOS window). My solution works, but I'd still rather do it the "right" way if possible.

djwillfund
09-21-2005, 03:04 PM
I'm having the exact problem and have spent several days researching the issue. No joy. The solutions proposed in the KB and by other users here don't seem to work. About the only thing I haven't tried is to do a CA, which I'm going to attempt next as a last resort.

If anyone has solved this problem, I'd sure love to hear about it. I'd be tearing out my hair if I had any!