PDA

View Full Version : Error Code -5009



asha.raichoora
06-16-2005, 06:05 AM
We have migrated installshiel 5.5 to Installshield 11 . After building the project we receive the following error :
Error Code: -5009 : 0x80070006
Error Information:
>Ctor\IScriptWrapper.cpp (27)
>Ctor\ObjectWrapper.cpp (163)
>Ctor\ObjectWrapper.cpp (391)
>Kernel\Component.cpp (1163)
>Kernel\CABFile.cpp (384)
>SetupDLL\SetupDLL.cpp (1526)
PAPP:CAST-2003
PVENDOR:Radical Limited (www.radicalglobal.com)
PGUID:8B66A3A1-0AAF-4641-AAAD-FCA95778C702
$11.0.0.28844
@Windows 2000 Service Pack 3 (2195) IE 6.0.2600.0

Can anybody help? Many thanks

radrevere
06-16-2005, 11:16 AM
I basically got that same error after I upgraded from 7.0. When I ran into THis error I had custom dialogs in source control so they were read-only. Hi-jacking the files took care of the error. Also, make sure that the setup.obs file is not read-only since it needs to be re-written on every build.

I almost forgot, if you have both versions installed you need to find a way to clean up the old runtime engine. Basically it is a conflict between the two and the new stuff can't find what it needs in the old stuff.

I un-installed, cleaned all folders and registry entries and then re-installed in order to get it to work.

leokrlewis
06-19-2005, 02:48 PM
I am getting the same thing with my install and it may have something to do with the InstallShield 11 Script Objects I had tried to install and it gave me the same message so it failed. I looked at this thread so I uninstalled InstallShield 11 Pro, cleaned the registry, removed any files from InstallShield 11 directories and installed again. Then I installed the InstallShield 11 Script objects and it gave me that error. So now I am going to uninstall for the last time and reinstall and not install the InstallShield 11 Script object and see if that fixes it. I also installed the HotFix 3 on each install. I will let you know what I find.

Kenneth R. Lewis
Intuit, Inc.

leokrlewis
06-19-2005, 03:28 PM
I have uninstalled InstallShield 11 Pro and reinstalled and didn't install the InstallShield 11 Script objects and I still get that error when I try to run my install or run in debug mode. Until I get this fixed I cannot run my install at all so I am stuck without a paddle.

Please help.

Kenneth R. Lewis
Intuit, Inc.

leokrlewis
06-19-2005, 03:51 PM
Found the fix and it was on this website cool ;)

http://community.installshield.com/...0532#post320532

Driesqu
06-21-2005, 01:38 AM
Hi,

I can't open this link you placed there, can you give me the complete one

Bobtcny
06-21-2005, 07:15 AM
Found the correct link.

http://community.installshield.com/showthread.php?p=320532#post320532

Somebody
06-21-2005, 09:35 AM
Looks like this error may be addressed in the InstallShield 11 HotFix 3:

http://support.installshield.com/kb/view.asp?articleid=Q111458

Mark R
12-20-2005, 04:56 AM
Hi Somebody!,

>Looks like this error may be addressed in the InstallShield 11 HotFix 3:

I have HotFix 3 loaded and I am still getting error 5009 with new installs in some clients.

Mark.