PDA

View Full Version : Component installed even though feature's install level is 0



bigredgum
06-13-2005, 08:41 PM
I have a Basic MSI project, InstallShield v11. I am new to InstallShield, so perhaps I am making a beginner's mistake.

I have about 8 features set up, and each feature contains a number of components. Each component contains a single .NET assembly. Most of my .NET assemblies use the dependency scanning (since that was the default....in any case, it doesn't seem like it works right). The problem is that, for a couple of my features, even if I don't install the feature via the Custom Setup screen, a few of the feature's components are installed anyways.

I have tried quite a few things to solve this issue, but to no avail. I have tried deleting and re-adding the components that are improperly installed. I have double-checked that the components are matched up with the correct features by using the Setup Types view (as well as the FeatureComponents MSI table). And I have run msiexec with the /l*v flags and looked through the log file. The correct features are listed as being installed, and yet the log file shows that some of the components that are members of uninstalled features are installed.

Again, this only happens for 2 or 3 of my features, and only SOME of the components in those features are installed when the feature is not.

Does anyone have an idea what the issue could be? I'm about at my wits end.

Thanks in advance.

bigredgum
06-13-2005, 09:06 PM
It always seems that you figure something out right after you post to a newsgroup.

I removed dependency and property checking from every .NET assembly component in my installer, and the problem went away. All features now install the correct components.

So I guess .NET dependency checking doesn't work, unless someone wants to correct me on that.