PDA

View Full Version : IS creating a new duplicate subfolder when compiling???



cada0310
06-09-2005, 01:24 PM
Hi there,

I have a project located at C:\FOO\FOO.ISM, lets say. There's a subfolder called Script Files, which has SETUP.RUL in it, natch.

For some reason, when I compile it, IS creates another subfolder and puts some of the SETUP.RUL output files in it - for example, there will now be a folder called C:\FOO\FOO\Script Files created.

This is really screwing things up; for one thing, it's completely broken my #include directives - I can't even include IFX.H, because it can't find the include files that IFX.H has in it.

I'm guessing the two are related, because it seems to be some sort of path issue?

Help!

cada0310
06-09-2005, 01:56 PM
I can see the problem; somehow <ISPROJECTDIR> got an extra level of directories in there, so it says C:\FOO\FOO rather than just C:\FOO, and it's screwing my whole project up.

How can I change this?

cuchac
06-30-2005, 12:18 PM
I had same problem. The only solution is manualy rewrite ISPROJECTDIR to right value and set "type" to "2" ....

Lyle Salam
07-12-2005, 12:17 PM
Same issue here too.
I have been building with the standalone build using projects brought forward from IS 6, then 10, now 11.

I believe I used to be able to edit and save a project with the IDE without this issue but it appears that when I attempt to specify where to save the ism file it puts it in a folder above where is select, and then the ISPROJECTDIR is changed with an extra installshield folder. I applied hotfix 3, but still have issue. I will report issue.

sbrinkmeyer
04-09-2007, 04:52 PM
so there are references to this same issue in other threads here. This deals with when the project was initially created and if there was an option in the earlier versions as to where the files should be created (with project file or sub-folder) from what i have read; there has been references to the ISPathVariables direct edit table and the ISPROJECTDIR row needing a 1 in the type. in the version of IS that i am using (11) this option is already set appropriately.

in order for me to make this work i had to go in to the direct editor and put a "1" in the "Value" column. this made the upgraded project file stop appending the name of the ism to the folder structure when it created the build.

after doing the manual changes in the direct editor you can see the changes immediately in the "Path Variables" screen.

this fixed this issue for me.
thanks
-scott