PDA

View Full Version : Problem after converting IS Skript from IS6.30 to IS 11



MrMijago
06-09-2005, 10:17 AM
Hi @ All,

i have opened my InstallShield 6.30 Project with Version 11 of IS. The Project was converted successfully. No compile errors or warnings.

I launched my generated setup.exe and the Program installs until the Finish Dialog comes. I have clicked on the Finish button and then the setup crashes. No error message! My setup is still running on the task bar but there is no reaction. I must kill the task with the windows task manager!

I have debugged my IS Project but all of the functions are correct.

On other machines the same error occurs.

My OS: Win2000 Service Pack4, Install Shield 11 German Professional with Hotfix installed.

Andy ideas?

Many thx...

Patrick

Somebody
06-09-2005, 10:58 AM
Do you have any SdShowMsg() windows active at the time you are clicking the "Finish" button?

MrMijago
06-09-2005, 12:18 PM
No, there are now SdShowMsg Windows!

I have reduced my installshield script functions on a minimum, so that only the files are transfered! The same error! I have deactivated my SdFinish Dialog Window too, but on the end of the installation process crashes the installation again!

MrMijago
06-10-2005, 02:25 AM
@Somebody:

I have found the error! Your idea was great! It was a SdShowMsg Window which was created with the TRUE Parameter but there was no call in the script to deactivate the SdShowMsg Windows (with the FALSE Parameter).

Very interesting, because i did not see any window with this Message. InstallShield 6.30 was running good with this script! :)

Thx a lot!

Patrick

Somebody
06-10-2005, 09:21 AM
Great!

In InstallShield 5.X, 6.X, and 7.X, if an install ended via an abort or normal exit with a SdShowMsg() window active, it seems InstallShield cleaned everything up properly and ended. But, starting with InstallShield DevStudio 9.0, the identical code and situation would cause the install to hang.

MrMijago
06-10-2005, 09:34 AM
Strange, very strange!

However, now it´s working!
Thanks a lot for the tip!

Patrick

ibratanova
02-10-2006, 05:01 AM
Hi,

I have similar problem - when script is aborted - it can not finish. The abort called from FeatureOnInstalled event, the only window was the progress dialog from IS, I even added SdShowMsg("", FALSE); call before abort - see below, but this does not help. What else can I try? As well it happenes not on all PC - without language pack it works OK without tricks.

if (SprintfBox(MB_ICONEXCLAMATION|MB_RETRYCANCEL, "", szMsg ) = CANCEL) then
SdShowMsg("", FALSE);
abort;
endif;