PDA

View Full Version : Error when running upgraded installation



halcyon
05-09-2005, 06:45 PM
I just upgraded my project file to run with InstallShield 11 and re-compiled. Now every time I try to install my product, I get the following error:

"An error occurred while downloading the file http://www.installengine.com/cert05/isengine/ISScript1050.Msi. What would you like to do? Retry/Cancel."

And of course, it never finds the file. Is anyone else getting this problem?

halcyon
05-09-2005, 07:58 PM
Actually, I think I may have fixed the problem. If you have any custom setup prerequisites, apparently you have to copy all those files from your "10.5" folder under Program Files to the "11" folder. Kind of a pain. :P

halcyon
05-09-2005, 08:08 PM
No, that didn't fix it. I don't know why this is happening! :eek:

Bubble Maker
05-10-2005, 10:09 AM
Hi halcyon,

for me it seems that your installation tries to download the scripting engine from the web. This is set in the release settings:
InstallScript Engine Location -> Download Engine From The Web
InstallScript Engine URL -> your broken link

If you need the scripting engine try to use 'Extract Engine From Setup.exe' or
'Copy From Source Media'.

The ISScript1050.Msi is located in <ISProductFolder>Redist\Language Independent\Legacy\1050 or try to use the new <ISProductFolder>Redist\Language Independent\i386\isscript11.msi.

Maybe this helps.

RobertDickau
05-10-2005, 10:31 AM
Or perhaps change the InstallScript engine URL to: http://www.installengine.com/cert05/isengine/ISScript11.Msi.

halcyon
05-10-2005, 04:04 PM
Thanks for the replies, Bubble Maker and Robert. Well, I only get this error when I run after doing a command-line build. When I build in the IDE, I don't get this error when I run (version 11 of the engine gets downloaded), but I get another one instead: "The wizard was interrupted before (name of my product) could be completely installed."

Sigh. At this point I'm just doing damage control. Since uninstalling 11 messed up 10.5, it looks like I'm going to have to uninstall and then reinstall 10.5. :mad:

halcyon
05-10-2005, 04:48 PM
I reinstalled 10.5 and everything seems normal again! :) I guess I'll try 11 again in a few months--after the first service pack. ;)

halcyon
05-10-2005, 06:50 PM
I discovered that the command-line problem is my fault. I needed to update the path to point to the newer folder. As for the problem I get when I run it, well, Technical Support is still working on that one. :) They do think it's related to my Installscript Custom Actions.