PDA

View Full Version : Error 1628 for QuickPatch on not matching base version



JoFischer
03-03-2005, 11:04 AM
Hi,
I did a test how a 10.5 QuickPatch reacts, if I invoke it on a computer which does not have the software version installed, which is the base version for the QuickPatch.

The result is error 1628: failed to complete installation.

This use case is not that exotic as any customer might get a patch and by accident try to apply it on a computer with a not appropriate software version. The standard error message is poor :( .

Is there a way to handle this in a more user friendly way?
Can I catch and handle this situation in my scripts (my project is MSI Script)?

Thanks :) ,
Jo

anitabs
03-07-2005, 02:47 AM
Hope this link helps you in resolving the issue.

support.installshield.com/kb/view.asp?articleid=Q107319 - 13k

JoFischer
03-07-2005, 05:59 AM
Dear anitabs,
I know that articles already (I know how to search the KB) - it does not describe my situation (I assume that InstallShield has errors in the KB in the same way as it has errors in the product :( ).

The very simple situation is, that I run a QuickPatch on a computer which does not have the software version installed for which the QuickPatch has been built.
If I run the same patch on the same computer after havin installed the correct software version, the patch works fine.

None of the causes listed in the KB article maches my situation.

Regards,
Jo