PDA

View Full Version : How can I prevent an InstallScript MSI Project from installing .NET Framwork 1.1 SP1



Danillo
01-25-2005, 11:08 AM
Hi guys,

I want to prevent an InstallScript MSI project from needing to install the .NET Framework 1.1 SP1.

I'm using InstallShield 10.5 SP1 and have configured the installation to include the .NET framework 1.1. When compiling the setup it comes up with the -6347 error because of missing DotNet Redist. I've downloaded all files until the compile finished without errors. I had to download the DotNet redists for 1.1 and the update redists for 1.1 SP1 to succeed.

After doing all that work I wanted to configure my project to install .NET Framework 1.1 without the SP1 but didn't find any settings. Can anybody help?

Just if you wonder: the reason why I don't want to update to SP1 .NET framework is, because this forces a reboot, what let's my very strange installation fail (selfprogrammed Setup.exe :o that triggers my products MSI and some additional MSIs).

Regards
Daniel

JStone
02-15-2006, 07:19 AM
Hi,

This article recommends to create a setup prerequisite to install .NET 1.1 without SP1. If you have already seen this, please ignore.

http://support.installshield.com/kb/view.asp?articleid=Q111502

Danillo
03-02-2006, 06:17 AM
Thank you JStone, was a good hint. Will take it into account when i refurbish my setup.