PDA

View Full Version : MDAC Merge Modules



mpowerdev
01-18-2005, 11:11 AM
Hi all:

I have a basic Windows Installer project targeting Windows 2000 and up. The software I am installing is a .NET 1.1 solution and I am using InstallShield 10.5 SP1 to install .NET 1.1 on the target machine (which works).

My problem is that I also need to install MDAC 2.7 (or 2.8) on the target machine. I have tried to use the InstallShield 2.7 and 2.8 merge modules (separately of course) and I always seem to get the same error message before InstallShield ever attempts to install MDAC:

"MDAC 2.7 needs to be installed for the installation to continue"

That's exactly why I have included the MDAC merge module in the installation! Does anybody have any ideas as to why this would occur?

Any help would be greatly appreciated and many thanks!

svasilyev
02-14-2005, 01:33 PM
...I always seem to get the same error message before InstallShield ever attempts to install MDAC:

"MDAC 2.7 needs to be installed for the installation to continue"

That's exactly why I have included the MDAC merge module in the installation! Does anybody have any ideas as to why this would occur?


I guess you have MDAC 2.7 listed as a prerequisite for the project. Check conditions in project properties