View Full Version : .NET Framework 1.1 doesn't install

12-30-2004, 09:11 AM
I have a strange problem. I've included the .NET framework 1.1 from the Release Wizard and selected:

version: .NET 1.1
Extract from setup.exe

The install script asks if the user would like to install the .NET framework, it extracts:


and then doesn't actually install the framework. It just begins to install the files that need the framework.

So, what I tried to do then is use a custom action and actually include the framework files myself, and they actually begin to install, but I get a weird error message about an "install already in progress". At what stage do I need to do the .net framework install if I'm doing it from a custom action? Or, what's going on with the release wizard?

An answer to either one would be fine.

12-30-2004, 11:19 AM
For the first, please make sure you have applied SP1 for InstallShield 10.5; if you still see this behavior with SP1 in place, I'd appreciate if you could help me reproduce it. Any specifics about the machine onto which you are trying to install the framework might help. E.g., are there any registry entries under HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\NET Framework Setup\NDP\v1.1.4322 that suggest it is already installed?

For the second, the .NET Framework is an MSI installation. As such you cannot launch it from anywhere in your execute sequence. Furthermore it's really tricky to do right (if it's possible) from the UI sequence and that's assuming you don't have any users who want to install your application silently. This is why the .NET framework installation is generally handled as part of the InstallShield boostrap.

12-30-2004, 02:16 PM
I've done the upgrade and I still have the same problem where it extracts all the correct files, but still doesn't actually install the framework. Is there a way that I can verify that the Service pack was applied correctly?

I'm running InstallShield 10.5. I have built both a Basic MSI project as well as a InstallScript MSI project, and they both have the same issue. I'm running Windows XP on a DELL Latitude D505.

The release wizard steps (for basic msi project):
Media Type: Network Image
Compress all Files
Create installation launcher
Extract Windows installer from Setup.exe
Cache on local machine
(No signing)
(No password or copyright)
Include or set up .NET Framework (1.1 - Extract from exe)
(No command line)
(No command line for language package)
(Not include Visual J#)
Use long file names

That's it. Nothing special. No custom actions, one single feature that contains the file I'm testing and still the .NET framework will not install when I include it in my project.

12-30-2004, 02:26 PM
Is it possible I have the wrong dotnetfx.exe file? Does InstallShield need the file that is downloaded from the redistributable download menu item? I believe that is the file that has been included in the install script, but how can I be sure? It's been marked as downloaded, how can I get that file again?

12-30-2004, 03:31 PM
ok, so i uninstalled InstallShield 10.5 and reinstalled and now it works. Thanks for the help.