View Full Version : Error 1328 and a fix that worked

Brad Peterson
12-27-2004, 11:55 PM
This is another annoying problem I found which I eventually fixed, and I felt it would be helpful to post the information here, so it could be of use to others if they run into it as well.

While running a patch, I ran into this problem

Error 1328

Error applying patch to file C:\config.msi\[some .tmp file]. It has been updated by another means, and can no longer be modified by this patch. For more information contact your patch vendor...

The error displayed when I was trying to patch an existing file (in this case, the main .exe file). In InstallShield Express X, when you select the newest version of the file to patch the old file, then underneath the pathname, there is a checkbox that reads "Overwrite Any Existing File - Select this option to include this file into your setup as a whole..." It turned out the patch that gave me the error 1328 left that box unchecked. When I checked the box, rebuilt and ran that patch, it worked.