View Full Version : SQL Script Text Replacement failing

12-08-2004, 03:48 PM
I have a large number of scripts that use text replacement to replace _INTEGRATIONPROCESSING_ with an SQL account name that is created during the install.

The replacement text is correctly obtained from the associated property, in this case "account", (and "account" exists in the database), but the script fails because it is trying to grant EXEC privileges to "_INTEGRATIONPROCaccount", i.e., the replacement text is simply overwriting the final, (in this case 7), characters of the string to be replaced.

Bug? Feature? Something I'm doing?

I'm using 10.5 Pro

Thanks - Ben

12-08-2004, 04:59 PM
Well, a workaround at least. I used a login name with the exact same length as the string to be replaced and it works.

12-09-2004, 10:38 AM
This is still failing, for me. IS ran a script and only replaced the first value (I had 2 GRANT EXEC statements). In the database I saw the first one granted, but then the script failed and the install rolled back because the 2nd one wasn't replaced. (I didn't have the 'replace only first occurence' checked).

I tried replacing with the exact same length of string and it worked fine.

Yesterday I tried the same or greater amount of characters for replacement and that worked, but now I'm back to *exact length only*.

Any ideas? IS: looks like there may be some buggy behavior here.. is this IS or Windows related?

Thanks - Ben

12-14-2004, 03:33 PM
This issue has already been reported by other customers and we have the work order #1-10CIHD to address it in a future release. We are also planning on publishing a hot fix for InstallShield 10.5 users. The hot fix should be available within a couple of weeks.

Best Regards,
Hidenori Yamanishi
Macrovision - Software Technologies Group