View Full Version : .Net Scan At Build - Error 6213

Tim Owers
11-23-2004, 05:21 AM
I have a v10 project that contains a lot of .NET components with their '.Net Scan at Build' option set to 'Dependencies and Properties' and builds fine. Upgraded the same project to 10.5 and now the build fails with an error 6213. This project has been upgraded to v10.5 on several different machines and all fail at the same place with the same error.
The only way way to prevent the error is to reduce each components scan type to 'Properties Only' (this also proves it's not one particular component causing the problem as the error just moves down to next component).

Until this bug is fixed I have to carry on using v10 and having just spent several thousand dollars on new licenses and upgrades I'm not very happy! :mad:

InstallShield please fix and patch this ASAP.

11-23-2004, 12:05 PM
I've heard (rumor-level) reports of this, but nothing we've reproduced in house. Until we can reproduce it, it's virtually impossible to fix. Do you have some sort of minimal case, ideally with one component with one .NET DLL or EXE, possibly with a dependency on another one or two such files, that reproduces this problematic behavior and you could send to me? I'd love to help solve this for you.

11-29-2004, 08:41 AM
I too am having the exact same problem! I just "upgraded" to 10.5 in hopes of fixing problems I had with InstallShield 9.0 regarding COM+ components that are .NET assemblies.

The problems is worse now! I can't even build now, where with IS 9.0 I could at least build before I got an error during setup. It's unfortunate that part of my job has become debugging InstallShield products. That would be OK if I was being paid for it. But as it is, I have to pay $754.94 USD to have the priviledge to debug your software.

Now that I got that off my chest, I will try to provide a reproducible IS project that you can fix.


11-29-2004, 11:45 AM
Tim was able to provide me with a reproducing sample. It appears the issue in his test case was only applicable to a .NET dependency being included in the same setup. Either removing the dependency from the setup to let it be included manually (only works if the automatic settings suit you), or removing the Dependencies portion of the .NET scan-at-build should provide temporary workarounds.

If you create a small reproducing case and you would like me to verify that it is indeed the same problem, please contact me directly at murman@macrovision.com and I can add anything I find to our Work Order #1-10CQYX.

11-30-2004, 12:06 PM
Just want to mention that I had the same problem - Build Error 6213 when one file has a .NET Dependancy on a C++ DLL included in the same setup. This was something that worked fine in InstallShield X, but not in 10.5. I disabled the Dependancy Scanning on that file to work around the problem.

I will have to agree a bit with Tim and ddeward... it is a bit disconcerting to pay so much for a ".5" update, only to find that it breaks more than it fixes. Since the 10.5 update, I have spent more time debugging InstallShield issues than problems in our actual software. As the person who was championing the "InstallShield Cause" in my company, it doesn't reflect well on me...

Andreas Isler
12-01-2004, 11:48 AM
I also have the same problem. DevStudio9 was ok, not so IS10.5. For luck I'm just evaluating IS10.5. As long as Macrovision doesn't offer a patch, I will wait.

12-02-2004, 11:21 AM
Upgrading from 10.0 to 10.5 I've discovered error 6123-

Why worst then others? because the origin is a MSM component from Crystal and I cannot turn off net scan on a MSM as suggested....

... for some project I'm still using version 8....


12-02-2004, 04:45 PM
I just want to report the same problem. I created setup project in InstallShieldX Express edition evaluation copy. We've just bought verion 10.5 prefessional edition. I loaded the project and converted it. When I tried to build, I got .Net Scan At Build - Error 6213.

I want to say that I am very disappointed with this product.

12-03-2004, 10:49 AM
Now that I've moved on to my second Installshield "upgrade" to 10.5, I get these errors. However, I was able to make this go away the setting the ".NET scan at build" to NONE previously, I can't make this go away the that workaround. Any other suggestions? I would start with a blank setup, but this one I'm working on now is huge.

C:\Program Files\InstallShield 10.5\IsDev.exe\-6245
C:\Program Files\InstallShield 10.5\IsDev.exe\-6213
ISDEV : fatal error -6213: Internal build error

Tim Owers
12-03-2004, 10:51 AM
Set the components key file to none.

12-03-2004, 11:10 AM
Brilliant! That works.

12-03-2004, 11:17 AM
I just wanted to poke my head in and say that setting the key file to None works because it implicitly disables the .NET dependency scan for that component. I don't know whether doing it indirectly (that way) or by explicitly changing your .NET scan at build settings makes more sense in your project, but be aware that it will not be searching for .NET dependencies in either scenario.

12-03-2004, 11:44 AM
What is the time frame for getting this fixed?

12-07-2004, 02:00 PM
I also get this problem which also went away when I set .NET Scan at Build to none.

12-07-2004, 02:55 PM
I just wanted to poke my head in and say that setting the key file to None works because it implicitly disables the .NET dependency scan for that component. I don't know whether doing it indirectly (that way) or by explicitly changing your .NET scan at build settings makes more sense in your project, but be aware that it will not be searching for .NET dependencies in either scenario.

Does it disable the .net scan when installing on the target machine? Or does it just disable the scan when doing the installshield build?

12-08-2004, 12:09 PM
What is the time frame for getting this fixed?We've got a hotfix coming shortly. If testing goes well I hope to see it released within a week.

12-08-2004, 12:10 PM
Does it disable the .net scan when installing on the target machine? Or does it just disable the scan when doing the installshield build?I'm not sure what Install-time .NET scan you're talking about. If you mean for installing the .NET framework, that's completely separate, and will not be disabled by this. If you mean something else, please clarify.

12-16-2004, 05:40 AM
I've just updated 10.5 to SP1 with integrated updater...

I've immediatly rebuild the only project I had converted (then I stop and continued to use version 10), but the problem still remain as you can see on attached build result file.

Hope this help and someone in Macrovision can find a definitive solution.


12-16-2004, 09:59 AM
Michael, any status on this?

12-16-2004, 11:06 AM
By the time we had the bug report and fix ready, the SP was deep in the QA process, so the fix isn't in the SP. However we have a hotfix planned (including this fix) that should be coming out really shortly, at least last I heard. I'll check on this today.

12-17-2004, 04:39 PM
Not that it matters much, but I am experiencing the same error and am waiting for the soon to be released fix. (What's ironic is that this problem occured one week after I completed a survey in which I expressed how well the last two IS updates had gone for us)

12-21-2004, 02:46 AM
what does really shortly means ?

Santa is coming... there are 8 days before end of year...



P.S. of course we have to release in 2004....

12-21-2004, 11:38 AM
Unfortunately it means it's taking longer than I expected. (I must be naive). If you are interested in testing a "fix" that could break other functionality (it hasn't finished going through our QA process), contact me via email: murman@macrovision.com

01-05-2005, 03:38 PM
Talked with technical support. Error -6213 is a Known Issue. They are working on the solution to this and will have an update to fix this issue soon.

Until then on my InstallShield 10.5 using a MSI project, Fixed the -6213 Error by doing the following: (In Order)

1. Clicked on "Installation Designer" Tab.

2. Under "Organization" chose "Setup Design".

3. Opened up the Features listed in it.

4. Selected each file and looked for ".Net Scan at Build".

5. Changed the value to "None".

6. If more files, go to step 4.

7. Rebuilt the Installation.

This fixed the problem.

Hope this helps someone else until they have the bug fixed.


Tim Owers
01-06-2005, 04:01 AM
Please read entire thread to avoid posting duplicate 'help'.

01-17-2005, 04:18 PM
I, too, have this same problem in upgrading a project from ISDev 9. Now I wanted to update to see if COM registration of .NET assemblies has been fixed. The problem was that the ComRegisterFunction and ComUnregisterFunction were not being called, and regasm had to be run manually after the installation was completed. That's not what it should be.

So count this as a vote to fix this problem and release the fix QUICKLY! I will volunteer to be a test guinea pig.

01-19-2005, 11:30 AM
Reading the thread I have a large project with this problem. I just added 5 .Net files and was getting the build error.
Created a small app with just the 5 .Net files and would still get the build error.
Now its down to 4 files. I found the EXE file was not needed.

Files to create the problem in InstallShield 10.5 [Basic MSI Project]
(Note Add .NET 1.1 to your Release)


If you run with .NET Scan at build set to (Dependencies and Properties) you should get the error.

Change AxInterop.SHDocVw.dll .NET Scan to (Properties Only) and Build, you should see the following.
Merging OLE DB 2.1: c:\program files\installshield 10.5\objects\OLEDB21.msm
ISDEV : warning -6638: The merge module 'OLE DB 2.1'
requires one of the following merge modules also to be included in the setup:
Microsoft Data Access Components 2.5
Microsoft Data Access Components 2.6 (English)
Microsoft Data Access Components 2.7 (English)

Add MDAC 2.7 Redistributables and the warning is gone.

Have not been able to change back AxInterop.SHDocVw.dll .NET Scan to (Dependencies and Properties).
Hope this helps.

Christopher Painter
01-24-2005, 12:08 PM
I just pulled a project out of VSS that we did last summer using IS Dev 9 and I'm getting -6213 errors right out the door. We are running 10.5 now.

Has a hotfix for this been made available yet?

01-25-2005, 07:36 AM
I encountered this bug as well and setting all of my .net components to "None" for scanning also resolved the issue. However, you need to set that value to something other than "None" in order to install files to the GAC. I have determined that you can set them to scan "Properties Only" and still successfully install files to the GAC.

I opened up a support request with Installshield on this and got the "This is a known bug and a work request has been filed" message, so I don't think they have a beta hotfix ready for any of us.

Tim Owers
01-25-2005, 07:41 AM
Read an entire thread before posting duplicated information!
It saves both poster and reader wasted time. :mad:

Christopher Painter
01-25-2005, 07:45 AM
If you read the whole thread you will see an offer from MichaelU.

01-27-2005, 06:16 PM
Hello all, Great news: The Hotfix fixing this -6213 error is available for download (http://saturn.installshield.com/is/10.5sp1/hotfixes/windows/hotfix_1_10jsd5_1_112xhh_1_113qq9_1_11qc01/hotfix1update.exe). I'm told this has gone through QA unlike the one I posted about before. As soon as I've heard this works for a few of you, my general offer from before for the beta will expire.

Christopher Painter
01-27-2005, 06:26 PM
I reverted the DLL and -6213 came back. Then I went to apply the hotfix and it said it's already been applied. The only other hotfix I've installed was for a SQL problem ( I'm trying to find the link I got it from ) and it seemed to have the same filename.

Edit: This is the SQL Patch


The URL in that KB and yours are the same. Did they rebuild the same package with a new fix? Because I applied the SQL hotfix I can't apply the .NET Hotfix.

01-28-2005, 11:51 AM
That hotfix is a group hotfix for approximately four problems, this one included (1_112xhh in the URL). I think we just failed to document that it was across all of these. If you had this hotfix installed, and still had the 6213 error, that would be a problem. If it's just when you applied the "beta" and then the hotfix, and then reverted, I think the hotfix includes the same version of the DLL as I sent you.

Christopher Painter
01-28-2005, 12:41 PM
The order was:

1) Install AdminStudin Studio
2) Slip stream the beta patch
3) Apply the SQL HotFix

All was happy then you said test the Hotfix

4) Revert the beta patch
5) Try to reapply the "new" Hotfix you told me about and it says it's already applied.

I will have to start over and do steps 1 and 3 on a clean machine to see if it's ok. But I'm catching a flight back east in a couple hours so it won't be today.

01-29-2005, 09:07 PM
The Beta hotfix had an updated DLL for the StandAloneBuild. I was not able to find one in the official release. Will there be one?

02-02-2005, 05:13 PM
I haven't found where we distribute this one any other way, so here's the updated file for the standalone build. Just backup your previous file and put this one in its place. If you have the version from the "beta" hotfix, I'm pretty sure this is identical.

02-15-2005, 03:55 PM
I have downloaded the hotfix and it seems to work great. All of my .NET projects seem to build fine now. If this is not the official release, will there be any problems upgrading to the released version of the hotfix?

Allan Thomson

02-21-2005, 10:20 PM
Please see this thread:


I can confirm that the hotfix fixes the .net dependency issues, but not the SQL issues related to the hotfix. Seems to only have a problem in the Stand Alone environment.

02-25-2005, 12:27 PM
For those of you following this thread and needing the standalone build to work with the SQL portions of the shared hotfix, you need to update three additional files. These are updated by the hotfix for the IDE, but I did not include or reference them above. Please retrieve them from your machine with the IDE and already-applied hotfix.

The three files are all under the InstallShield INSTALLDIR:
Redist\Language Independent\i386\ISSQLSrv.dll
Redist\Compressed Files\Language Independent\Intel 32\SQLRT.dll

And should be copied over their existing locations on the standalone build, which probably should mirror these locations. For safety please back up your existing files before putting these in place.

04-01-2005, 04:34 PM
I have tried to update our stand-alone build system, but I am still getting the 6213 error when I attempt to build. I downloaded the 10.5 SP 1 build system and then updated the three files frfom the last post from our full version of InstallShield. Unfortunately, the error remains. Is there something I have missed when updating the Stand-alone build system?


06-07-2005, 12:31 PM
I've came into this thread a little late. I'm a little confused on which order these things are supposed to be applied and what patch contains the SQL fixes.

Can you please recap the steps needed to get a good working Stand Alone build system with both the SQL and Hotfix for ISSABLD?

Tim Owers
06-07-2005, 12:51 PM
On the IDE machine install:

On the IDE machine install:

Copy from the IDE machine to the standalone machine:
Redist\Language Independent\i386\ISSQLSrv.dll
Redist\Compressed Files\Language Independent\Intel 32\SQLRT.dll

06-09-2005, 10:59 AM
we encountered the same annoying Error 6213 recently and tried performing all mentioned tasks:

1. installed the hotfix on the IDE machine
2. opened the zip file, but installed it on the StandAlone computer (since the file didn't appear on the IDE machine)
3. transferred the files mentioned to the StandAlone computer (could it be that only SQLRT.dll appeared before, and that i didn'y even have a Support directory, only ActivationSupport?)

all this didn't work, i'm still getting a .NET warning and a 6213 Error.
what did i miss?