View Full Version : Error 1607 when launching an install within an intall

11-18-2004, 01:04 PM
I am using InstallShield X - Express. I am copying files across to the destinations temp folder. Some of these files are for another written setup.exe. This is a third-party piece of software I want to install as part of my install.

My Install copies the files across and then runs the other setup.exe from their temp folder. After the other install splash screen appears I get the following error.

"1607: Unable to install InstallShield scripting run time"

This installation works when I double click on it normally but not within my install. Any ideas?

I have attached a screen-shot of the custom action I have created.

Thanks in advance


11-18-2004, 04:20 PM
You cannot have multiple instances of Execute Sequence running concurrently. For additional information, please look up 1607 in InstallShield.com Search (http://www.installshield.com/search/).

11-19-2004, 05:54 AM
Is there a way to run another setup.exe within my install?

Richard Peck
11-20-2004, 12:24 PM
I'm not even writing an installation routine. I'm having problems just installing anything on a new IBM X31 notebook. The notebook came with XP SP1 and level 6 of the InstallShield script engine. I updated to SP2 and tried updating to ISScript8.msi, but the problems became even more strange.

However, the problems do not appear to be SP2 related. (See this thread community.installshield.com/showthread.php?t=140998&highlight=1607 (http://).) The problem was worse under SP1, because application installs would appear to complete normally--but the app wouldn't be on the machine.

Now, when installing an application, this is the InstallShield message: "1607: Unable to install InstallShield Scripting Runtime."

When I tried to update from InstallShield 6 to 8, the dialog box shows the update proceeding normally but terminates, after rolling back everything includuing registry entries, with this message: "The wizard was interrupted before ISScript could be completely installed."

I've checked privileges (I have system administrator privileges). I've cleaned the temp directory. I've search IBM, Microsoft, InstallShield, and software application Knowledge Bases. I've phoned IBM's notebook tech support. They were baffled, although the ticket is open.

Help? Any ideas? With thanks in advance.

Richard Peck
11-20-2004, 12:30 PM
PS: Apologies if a cross-post to the SP1 versus SP2 thread duplicate this for some on this list.