View Full Version : .NET Framework 1.1 redist broken?

11-16-2004, 04:35 PM
I have checked the "include or setup the .NET framework" in the Release Wizard, but when I attempt to install the generated install set on a machine that does not have .NET installed, the installer seems to get stuck while "configuring the .NET framework".

The progress bar just cycles endlessly, and although I have waited for at least an hour for the installation to complete, it never seems to get past the .NET framework install.

On the target machine, I can see that dotnetfx.exe is a running process, but doesn't seem to be consuming much CPU time.

Any help would be greatly appreciated.

11-16-2004, 06:58 PM
Yes, we've found this behavior and intend to address it ASAP. I'll follow up on this once I have more information.

Stefan Krueger
11-17-2004, 12:01 PM
I've seen this when I tried to install the dotnet redist in silent mode.

11-18-2004, 04:39 PM
I am also having this problem. It seems that the problem is with the "dotnetfx.exe" located in the "Redist\0409\i386" folder. If you replace this file with the version used by InstallShield X, the installer no longer gets "stuck" and the .NET Framework 1.1 gets installed (without the service pack, though). Obviously, this isn't a nice long-term solution (I'd like to distribute and install the service pack as well), but this is how I've bypassed the problem for now.

11-18-2004, 05:44 PM
As a bit of a warning, I'm not quite sure what the behavior will be with regard to .NET 1.0 if you take this strategy. The build will provide 1.0SP3 files, but the old dotnetfx will look for SP2 files.

It's "fine" for 1.1 because there was no previous SP, so the extra SP1 files will be safely ignored. If you build uncompressed I think you can just delete them.

11-18-2004, 07:31 PM
Yes, obviously this is not what I'd like for a long-term solution, but at least it seems to bypass the problem for now (since I'm only worried about the 1.1 framework). I'm still hoping that an "official" fix to the .NET Framework-related problems will come soon (including the problem with some of the language packs)... this move to 10.5 hasn't been a very smooth upgrade process for me at all, unfortunately...

11-19-2004, 03:49 AM
We also got this problem on all clean PCs. MSI log contains the following lines:
MSI (c) (98:B0) [18:30:24:765]: ******* RunEngine:
******* Product: D:\DOCUME~1\mark.ka\LOCALS~1\Temp\1\ISD.tmp\netfx.msi
******* Action:
******* CommandLine: **********
MSI (c) (98:B0) [18:30:24:795]: Note: 1: 2203 2: D:\DOCUME~1\mark.ka\LOCALS~1\Temp\1\ISD.tmp\netfx.msi 3: -2147287038
MSI (c) (98:B0) [18:30:24:815]: MainEngineThread is returning 2

And this temp folder is empty! Also I found that removing value 1033 from DotNetCoreSetupUILang in setup.ini changes situation - .NET runtime installation starts, but ends with error, probably because of invalid argument "coreui".

11-19-2004, 01:24 PM
Anyone know if there is a fix coming for this issue. I'm in the process of evaluating InstallShield 10.5 for a .NET application. I definitely need support for installing the .NET 1.10 framework. The application will be installed on laptops without internet access, so the framework needs to be installed from the source media.

If this issue has been present for awhile without a resolution, I will need to look into another installer.


11-19-2004, 02:48 PM
Can someone post a copy of the "dotnetfx.exe" from version X so I can try the workaround Brian_C described. I'd really like to get the install I'm working on to install the .NET 1.1 redist from the source media.


11-19-2004, 03:25 PM
For everyone's information, we're in the testing cycle, and expect to release an updated dotnetfx within a month.

Fabio Pagano
12-16-2004, 10:42 AM
Does the Sp1 for IS 10.5 includes the resolution for the problems reported in this thread?

12-16-2004, 11:08 AM
Yes, the SP should include the fix for the dotnetfx.exe hanging and related issues.

12-16-2004, 03:52 PM
Yes, the SP should include the fix for the dotnetfx.exe hanging and related issues.Well, the good news is that, yes, in fact, in my tests today, an installer built with 10.5 SP1 successfully installed the .NET Framework 1.1 and Service Pack 1 without error. It required a reboot in the process, but it worked (installation continued after the reboot as expected). Yay!

Now, the only thing I would really like to see (and perhaps there is a way to do this already?) is a way to see the progress while the .NET Service Pack is installing. As it stands, the InstallShield window just sits there with the "Configuring .NET Framework..." message and an unchanging 100% progress bar. Would it possible to (optionally?) not install the Service Pack in silent mode?

Other than that, so far so good on this particular issue.

12-16-2004, 04:58 PM
Glad to hear it's working out for you, Brian!

Just to clarify some of my previous statements, the fixes described above are in this SP1, and for those who are reading along rather than eagerly refreshing the Update Service window, SP1 for 10.5 has been released.

Thanks for all of your patience for this update.

01-12-2005, 06:20 PM
When I had this problem, I pulled the framework out of setup and instead included it as a setup prerequisite. worked like charm. had the added bonus that if the user cancelled the installation of the framework, my install ended too.


01-16-2006, 09:00 AM
Hi Nancy,

When you made the .NET framework install a pre-requisite, did you just call the dotnetfx.exe? Did you manage to get it to install in quiet mode?

If so, how did you do it coz I don't want the user to have to interact with the .NET install at all, they must just see it installing.

I extracted the MSI and CAB files and passed /qn! to the MSI to silently install. But there seems to be a bit of a problem on some machines with this as it asks me to insert the install disk for .NET to install. But this error is not consistant and works on most machines.

Fabio Pagano
01-16-2006, 10:06 AM
dotnetfx.exe /q:a /c:"install /l /q"

But remember that Microsoft requires that the end user that installs your software must explicitly accept the framework EULA.

Read here:

where is stated that:
"The redistribution license does not grant the distributor the right to modify the installation process and suppress the EULA (enable silent install)."

03-03-2006, 04:10 PM
If you extracted the msi and cab files for the .net installation I saw in another thread that the msi file has a wrong entry in it. Here is the thread I found that has this. I'm just about to try this method cause all other ones have failed.

It really shouldn't be this hard to place .net install into a product installer. The release config of .net worked just fine but we also had a requirement for a silent install, which only would install .net and then exit without installing our product.


I still can't get .net 1.1 to list in the redistributables as a setup prerequisite even though its not listed in the available downloads.