PDA

View Full Version : 6028 error on build



Tony Patterson
11-08-2004, 04:20 PM
Hi,

I built 3 projects using the beta of InstallShield 10.5. Now I have upgraded to the full release of 10.5 and one of the projects is failing to build with a 6028 error. I have looked through the help and kb and it's less than useful.

My build log points to something in the file table i guess..

*****
Created release folders
AdminExecuteSequence table successfully built
AdminUISequence table successfully built
AdvtExecuteSequence table successfully built
AdvtUISequence table successfully built
InstallExecuteSequence table successfully built
InstallUISequence table successfully built
Directory table successfully built
Feature table successfully built
FeatureComponents table successfully built
Component table successfully built
Loading File table
ISDEV : fatal error -6028: Internal build error
*****

Any ideas as to what I can look for in there?

Cheers
Tony

RichAquino
11-08-2004, 06:49 PM
Hi Tony,

It sounds like this is project-specific.

In the project that doesn't build:
Are you using trialware?
Are you using VSIP project outputs?

Rich

Tony Patterson
11-08-2004, 07:17 PM
Hi Rich,

Thanks for your reply.
I am not using either of thos two (trialware or vsip outputs). I might just have to recreate the project and try to avoid whatever I did that caused this if there is no clear reason.

Tony

RichAquino
11-08-2004, 07:27 PM
Hi Tony,

It would help a lot if you could upload the project so we could debug building it. If you are not comfortable with putting it in a public forum, feel free to PM me, and I'll walk you thru how to FTP it to us.

Rich

MichaelU
11-15-2004, 01:35 PM
Hi Tony,

It looks like it's failing on build due to being in an inconsistent internal state in which it's missing an IS... table. Can I confirm that you worked on these projects (perhaps even created them) in the Beta build, and then when you opened it in InstallShield 10.5 proper that there was no migration?

If so, you should be able to work around this in one of a couple ways. I manually set the schema number back to 757 from 759 (InstallShield table in the direct editor), saved, closed, and reopened the project. You can do this a little more cleanly with the Save as legacy version 10.0, especially if the project doesn't contain use any of the newer features, or they're easier to recreate than to worry about the rest of the project being in an odd state.

After reopening with proper migration, I got past the -6028 error, and instead errored out where we don't have your files. :)

Let me know how this works out for you.

Tony Patterson
11-15-2004, 04:07 PM
Thanks Michael and Rich, that did the trick :)

Unfortunately I can't remember if there was no migration when I opened the project in 10.5 after creating it in the beta.


Thanks a lot guys.
Tony

tlipscomb
07-26-2005, 02:27 PM
Cause
Information about the cause of this build error will be documented in the future.

The above is documentation for Error 6028 that I received. And by the way, I have never used a Beta release. However, I am using 10.5. Is there any information on this error?

In addition, there is no support subscription for 10.5 and only pay-per-incident of a $100. Furthermore, my last pay-per-incident request took three days before InstallShield provided support.