PDA

View Full Version : Windows Installer 3.0 Redist



mr_anderson
11-03-2004, 11:29 PM
I was under the impression that Microsoft has not released the Windows Installer 3.0 redist yet. :-S I still am not able to find it on their site.

bobcorrigan
11-04-2004, 10:51 AM
Microsoft has indeed not yet delivered their MSI 3.0 redists. We expect them soon. When they arrive, we will make them available to InstallShield 10.5 both in re-build eval and e-shop downloads, as a download from the resource page, and ultimately we will re-burn our manufactured media to incorporate the MSI 3.0 redist.

Thanks,

bob

mr_anderson
11-08-2004, 11:17 PM
Windows Installer 3.0 redist is now available. Check the link for more information.

http://support.microsoft.com/?kbid=884016

psproxton
11-10-2004, 01:41 PM
I am trying to generate a patch in InstallShield 10.5 with the new MSI 3.0 redist in it. I have downloaded the redist from Microsoft, but what name and where do I need to put so I can generate a patch with the the redist inside my Update.exe and run silently.

I have tried naming it InstMSI30.exe and putting it in "InstallShield 10.5\Redist\Language Independent\i386", but that didn't work.

Thanx

David Thornley
11-10-2004, 02:13 PM
InstallShield 10.5\Redist\Language Independent\i386\msi3.0\instmsi30.exe

rowbot
12-08-2004, 06:20 AM
Hi, I can't get the 10.5 SAB to pick up instmsi30.exe...

ISDEV : error -7060: InstallShield requires that you provide the MSI 3.0 engine redistributable once it is available from Microsoft. Please copy MSI 3.0 RC2 engine redistributable file to <InstallShieldFolder>\redist\Language Independent\i386\MSI3.0\instmsi30.exe.

I copied it to that exact path using the same case for all directories...

Any ideas anyone?

CharlesW
12-08-2004, 10:24 AM
This is a known issue. The WO number is 1-110EO1 . It should be part of our planned IS 10.5 SP 1 being deployed soon. Users will receive an Update Service message when it becomes available for download.

Regards,

Charles Weber
Macrovision

mr_anderson
12-08-2004, 10:03 PM
I guess this is due to the reason that Microsoft decided to name the upcoming versions of its engines based on the KB number of the release. Thus the engine is not named instmsi30.exe.

rowbot
12-16-2004, 04:29 AM
Hi Charles, I've downloaded the SP1 update, but will this apply to the SAB as well as the IDE?

Thanks,

installboy
01-04-2005, 01:19 PM
Has anybody been able to bundle MSI 3.0 with their product by using the standalone build? I re-downloaded the "10.5" standalone build that the InstallShield Update Service shows and it does not appear to have been updated for the "10.5 SP1" service pack.

ib

bobcorrigan
01-04-2005, 03:10 PM
The InstallShield 10.5 SP1 Standalone Build Engine was just activated on the Update Service - check updates and you'll see it. This contains the new MSI 3.0 bits.

bob

rowbot
01-05-2005, 05:48 AM
I've just re-downloaded the 10.5 SAB (although there's no date/version to see if it's newer or not!!!), and the problem still isn't fixed. It still complains about not finding instmsi30.exe

arrgghhhh.....

bobcorrigan
01-05-2005, 10:49 AM
Have you installed SP1? You wouldn't see the new SAB unless you're running either 10.5 Professional or Premier with SP1.

installboy
01-05-2005, 11:30 AM
My Help->About InstallShield screen says:

InstallShield(R) 10.5 - Premier Edition
Version 10.5
Service Pack 1


I am not seeing the 10.5 SP1 standalone build when I check for updates. Does the update service's name or description of the new standalone build say "SP1" anywhere so I can easily identify it?

I also still see the SP1 for the IDE product as an available update -- not sure if this is normal for someone who already has SP1 installed.

ib

rowbot
01-05-2005, 11:56 AM
Hi, I've got Installshield 10.5 Premier Edition SP1 installed. I downloaded the SAB this morning and installed it on the same machine, and hit the problem again.

Thanks,

bobcorrigan
01-07-2005, 10:35 AM
OK, this is officially odd. We're on it, and will get it fixed ASAP. Stay tuned.

bob

Joshua
01-11-2005, 04:19 PM
The issue has been fixed, and InstallShield 10.5 Service Pack 1 StandAlone Build is now available via the Tools | Check for Updates in the InstallShield IDE. Sorry for the earlier mix-up, as many were not able to see the download info.

rowbot
01-12-2005, 07:13 AM
Can I make a suggestion?

It would be handy if the Update Service displayed a version and publish date/time for each item.... this would certainly reduce some confusion.

Thanks,

FinbarFitz
01-12-2005, 04:26 PM
The problem still existed in 10.5 SP1. Are you saying that there is a new SP1?

installboy
01-12-2005, 05:59 PM
FinbarFitz,

The "full product/IDE" version of 10.50 SP1 was released in mid-December. The 10.50 SP1 standalone build package was not released until a couple of days ago. The new standalone package is identified as "InstallShield 10.5 SP1 StandAlone Build Engine" on the update site.

I installed the new standalone build and verified that it does fix the problem bundling the msi 3.0 redistributable with my install.

ib

Marshall_C
03-16-2005, 06:31 AM
Can the standalone build engine be downloaded outside of the update manager, as it doesnt work through our corporate firewall