PDA

View Full Version : Problem with single executable



kapilvp
09-24-2004, 12:45 AM
Hi,
I have created an application using installshield demoshield 7.5 which I pack into CD.I call my mysetup.exe from this demoshield application. Now I gave the reference path for the mysetup.exe in the demoshield both of which lies on the CD but in different folder. mysetup.exe takes the reference of the data file which lies in the same folder as mysetup.exe. Now I wanted to create a single executable so that I can load that on the website.
The problem I am facing is that now when I run the appication mysetup.exe does not take the reference of the data file, while this works when I create a normal demoshield package not a single executable.

Please somebody help me out of the trouble.
Thanks in Advance.
Kapil P.

JoannaG
09-24-2004, 10:34 AM
Hi Kapil,

If I understand you correctly you have a demo that launches a single executable mysetup.exe. You would then like to package your demo as a single executable. When you create a CD Browser distribution the mysetup.exe launches correctly. But when you create a Single Executable distribution mysetup.exe is not found.

It sounds as though you did not import mysetup.exe into the Resource Manager. When creating a Single Executable, because files cannot be added after distribution, you must import all resources into the Resource Manager. The Resource Manager is found in the Demo menu. A setup.exe file can be imported into the File tab of the Resource Manager. I recommend you import mysetup.exe into the Resource Manager and then create a new distribution. If you directly import the file you can use <Temp>mysetup.exe<Temp> as the path. If you select Import by Reference when importing the file, the path should be <Path>mysetup.exe<Path>.

I hope this is helpful.

kapilvp
09-27-2004, 11:03 PM
Thanks JoannaG for the reply.

No, thats not the case. Now when I run my application it takes the referene porperly and mysetup.exe in executed. It normally reads the data file which is in the same folder as mysetup.exe but this is not happening in single executable.
I had imported mysetup.exe into the Resource Manager as well as my data file.
Here mysetup.exe reads the data file during installation and then performs a particular action which is not happening in single executable.

Waiting for the reply.
Thanks in advance.
Kapil P.