PDA

View Full Version : Big trouble after upgraded to X Express. Please help!



ebayweijun
08-27-2004, 06:43 PM
I got several problems after I upgraded from 4.0 SP1 to X.

1. When I click on any .ise file or try to launch Installshield X Express GUI I the "Installshield X Express Edition" dialog of the installer itself pops up, hangs for a while, then asked me to insert the CD. I inserted CD once, it went away, but after a while it shows up again when I run it again.

2. So I have to use Visual Studio 2002 to load the solution file that includes the .ise file. During this process, I kept getting those annoying windows in step2, I clicked "Cancel" for all of them multiple times, they went away and my project was loadded. But when I started to build the installer project, I got a lot error like this:

ISEXP : error -4072: Error retrieving dependency msxml3inf.B560EED0_07AE_45A2_BDB9_BED4D4DA518C:1033 of C:\Program Files\Common Files\Merge Modules\msxml3.msm
C:\Program Files\InstallShield X Express\IsIde.exe\-4072

But the installer was built finally.

3. Then when I ran the generated installer, it ran fine in my Windows 2000 machine, but at the end it asked me to reboot (it never behaved like this because I have both .NET Framework 1.0 and 1.1 installed). Then I tried to run it on windows XP, I got getting the "Error 1723. There is a problem..." and the installer can never go through.

Attached are screenshots of all errors.

Please help us to fix the problem ASAP.

Thanks,
-Weijun

Mike Marino
08-30-2004, 11:29 AM
1. Whenever Express tries to repair itself, it means that something got corrupted with the installation. The best way to remedy this, is to do the following:

A. Uninstall Express
B. Make sure the following folders do not exist (if they do, delete them)

C:\Program Files\InstallShield X Express
C:\Program Files\Common Files\InstallShield

C. Re-install

2. The error would be caused by:

msxml3inf_wim32.msm
wdstddll_wim32.msm

Not being on your system These Merge Modules are dependencies of MSXML3. They should be installed by InstallShield Express X to

C:\Program Files\Common Files\Merge Modules

3. These missing Merge Modules could cause the error in your installation. These Merge Modules do different things on different OS's.

Hope this helps.

ebayweijun
08-31-2004, 01:07 PM
The A-B-C re-install process seems to solve the problem for a while. But it popped up again in the next day so I re-installed it again. Not sure what in my machine is causing the problem.

It seems that Installshield does not install msxml3inf_wim32.msm and wdstddll_wim32.msm in my machine and I have to install MSXML 3.0 SP4 to get these 2 merge modules installed.

Thanks for help.

sauralf
03-10-2006, 03:15 PM
Ok, finally figured this out (was having the same problem).

If you're using SP4, you have to UNCHECK MSXML 3.0 and INSTEAD CHECK Msxml3 Exception INF Merge Module and WebData Std library in the redistributables area for the project to build sucessfully.

Its a bit strange to me that if you read the microsoft SP4 release notes (here (http://download.microsoft.com/download/d/9/8/d9886528-6438-4828-9094-697103203a32/MSXML3SP_RelNote.htm) ) that it also mentions msxml3_wim32.msm, which isn't selectable. I'm assuming that its being included in one of the other two.

None the less, this has worked reliably for me.

repins
07-19-2006, 08:33 PM
...if you uncheck msxml 3.0, how do you install the actual msxml3 dlls contained within it?
msxml3.dll
msxml3a.dll
msxml3r.dll

I'm not using the same version of IS, but trying to use the latest msxml3 merge modules (sp7) and after updating the following I get an error during packaging/building.

Modules:
msxml3_wim32.msm
msxml3inf_wim32.msm
wdstddll_wim32.msm

I get an error stating:
"File not found. An error occurred merging Module 'wdstddll.27F925D5_5B24_45D4_BB4C_7B86139C8385:1033' for Feature 'MyFeature'.

I'm stumped seeing as the module is clearly visible to IS when I select it from the redistributables section. Would seem there is some file in it that can't be found, but how can that be??? Funny thing is the msxml3_wim32.msm module doesn't list any dependencies and doesn't even list a version while the SP4 which had a file name of msxml3.msm does.