PDA

View Full Version : Unable to unistall application



Namshub
12-03-2001, 05:19 AM
I am a newbie when it comes to this product.

I used a scanned VB project to create my Install application.
I also used the MDAC 2.6 Merge Module, and Crystal 8.5 Merge Module.

When I try and unistall the application it runs the ado installation, then tells me to reboot the machine.

Done this and then tried to unistall, but it does exactly the same again. I have also tried running this unistall without rebooting the machine.

The client machine is a NT 4 sp6a.

What gives?
Why does it keep runing the MDAC module?

Please help, I cannot distribute the app until I can successfully unistall it.

Chandima
12-03-2001, 04:48 PM
Please download the latest MDAC merge modules from the installshield website. This is a known issue that was fixed a while back. I think these fixed modules shipped with Express 3.5x (but downloadable and usable by 3.0x users as well).

When downloading the merge modules MAKE SURE that you either delete or move the current msm files to another location (they are currently in C:\Program Files\InstallShield\InstallShield Express\Objects) and then download them. Otherwise (for some reason) the project still picks up the old ones and their bugs. Be sure to diwnload the DCOM merge module as well because it has a few fixes too.

Namshub
12-04-2001, 03:57 AM
Ok, so that stops me having the same problem in the future.

But how do I manually remove the applcation from the client machine. It is my test machine and I have to make sure that all files are removed (such as dll's and ocx's).

Cheers

Chandima
12-04-2001, 10:17 AM
You will have to manually edit the msi file cached on his machine. To do this you will need a tool called ORCA which comes with the Windows Installer SDK (Free download). One way to get this is

Go to Custom Actions View
Press F1
Navigate to the help topic "New DLL Custom Action Function Prototype". At the bottom of this page is a link named "web site". This will download the SDK for you. Install it and look in the tools folder. You will see Orca.msi. Run this msi and it will install ORCA. Now just right click on an msi file and select "edit with ORCA" and you will be able to open it in something like an Access database.

No on your users machine, locate the msi. On all machine except Win2K it usually is cached in C:\Windows\Installer under a cryptic name (like Hsg357.msi). If there are more than one you can open each one, go to the Property table and look at the ProductName.

Once you find the correct msi make a copy of it. Open the copy
1. Go to InstallExecuteSequence
2. Should have an entry for InstallMDAC.GUID (where GUID is bunch of numbers)
3. In this row's Condition column, add the condition "NOT Installed".
4. Do the same to the similar entry in the InstallUISequence Table.
5. Save the msi
6. Double click the msi and it should lauch the Maintenance Dialog from which you can uninstall the app. This should NOT launch MDAC.