PDA

View Full Version : Custom Bitmaps



mrbrianc
08-23-2004, 01:53 PM
After the "preparing to Install" screen, there appears a "Install Welcome" panel. We have customized this with a custom bitmap of 499 X 312 pixels. When it first appears, the bitmap is shown at about 50 times its normal size. After about 1 second, it resets and appears its normal size. Is there a setting we are missing to avoid this?

mrbrianc
08-23-2004, 02:18 PM
Upon further investigation, it appears that this happens because we had an improper bitmap size the first time we built the install. It remembered that bitmap and will not overwrite it. It appears for about 1 second before resetting to the proper bitmap.

Creating a new project has the same error except is shows the InstallShield default bitmap for 1 second before resetting to the custom bitmap. Is there a way to prevent this?

Mike Marino
08-23-2004, 04:44 PM
There is actually an MSI Dialog before InstallWelcome called "SetupInitialization" -- Not to be confused with the InstallShield Setup Initialization Dialog (the one with a Progress Bar).

The MSI SetupInitialization Dialog shows for a very brief time after the InstallShield Setup Initialization dialog and Before InstallWelcome. To change the Image on this dialog, you need to set the "Global Dialog Image". You can set this in the Dialogs view. Click on the Node above "Splash Bitmap" called "Dialogs" and set the Global Dialog Image on the right.

Hope this helps.

mrbrianc
08-24-2004, 04:30 PM
Thanks! That did the trick.

richardh
09-08-2004, 06:55 AM
Mike - I'm trying to do the same, but I appear to be missing a trick or two somewhere...

I cannot see the "Splash Bitmap" or "Dialogs" node in my InstallScript MSI project, and can't find any reference to "Global Dialog Image" either.

What am I doing wrong ? :o

Mike Marino
09-08-2004, 09:00 AM
That trick only works in InstallShield Express (4.x, 5.x or X). You need to modify the Setup Initialization Dialog in the Dialogs view in InstallShield Developer, or InstallShield X.

richardh
09-08-2004, 09:14 AM
Thanks for the prompt reply Mike....


but I'm very new at this :( By Dialogs View do you mean the "Dialogs" node under "User Interface" in the Installation Designer ? If so, I cannot see the Setup Initialization Dialog...

Sorry - just to let you know I'm working with InstallshieldX Professional.

Mike Marino
09-08-2004, 10:02 AM
What type of project are you using? (This is displayed in [] in the title bar).

richardh
09-08-2004, 10:03 AM
InstallScript MSI Project

Mike Marino
09-09-2004, 05:31 PM
Your best bet is to post this in the following forum:

http://community.installshield.com/forumdisplay.php?s=&forumid=136

It really comes down to which dialog you are actually trying to modify. If it is the Dialog that first pops up with the Progress bar...you cannot change the Bitmap. Although you can use the Support Files view (under Behavior and Logic) to specify a bitmap that gets shown instead.

If it is a dialog that shows up after the Initialization Dialog, in InstallScript MSI, you need to change this in the Dialogs view.

richardh
09-10-2004, 03:47 AM
Okey dokey

Cheers for the help Mike...