PDA

View Full Version : Error during setup 0x80040801



sbryan
11-29-2001, 08:33 AM
I'm hoping someone in this group can help me with this problem.
I have two programs that use Installshield and both cause the same error when it starts to install.

"Setup failed to run installation: (0x80040801)"
"An error occured while launching the setup. (0x80040801)"

On one machine they both run fine. On another they both fail.

The failing machine is a Pentium 4 running XP and the successful machine is an AMD running XP.

I've tried deleting the \Program Files\Common Files\InstallShield directory but that did'nt help.

The program vendor have been no help and say it's not a problem with their program.

Any help would be appreciated.

Stephen

Joachim Friedho
12-14-2001, 09:19 AM
I have the same problem. Dozend installations of our software are running, but one customer has the same problem. I haven't found any solution for this problem and i don't know where to search for a solution.

Joachim Friedhoff

Chandima
12-14-2001, 09:58 AM
Are you by ANY chance using the VBScriptRuntime merge module? We found (and fixed) an issue yesterday where this causes a crash on NT machines.

If not,
1. Have you included any merge modules? If so, what are they?
2. Are you running any Custom Actions? If so, dll, exe or vbs?
3. If possible log this install. It will provide a lot of information as to what might be failing. To do this, from the command line run

Setup.exe /v"/lv C:\InstallLog.txt"

If you get a log, post it and I'll take a look.

Joachim Friedho
12-14-2001, 10:44 AM
I do not use any merge module, no custom actions (no .exe, .dll or vbs).

When i try to use the command line switches

Setup.exe /v"/lv C:\InstallLog.txt"

no log file is created on my machine (where i do not have any problem with the installation)

When i take a look to the documentation of InstallShield Professional 6.1, i can not find these command line switches.

Thank you for any answer.

Chandima
12-17-2001, 09:14 AM
I'm afraid you have the wrong Newsgroup :)

This newsgroup is for InstallShield Express only. That's why those command line parameters are invalid. Please make this post on the InstallShield Professional newsgroup at http://community.installshield.com/forumdisplay.php?s=&forumid=42

Thanks.

Joachim Friedho
12-18-2001, 02:53 AM
Oops, sorry and thank you for the hint.