PDA

View Full Version : cfgmgr32.dll and MDAC2.5 Merge Module



Variable
11-27-2001, 11:26 AM
After installing and rebooting a WIN98 computer, the cfgmgr32.dll gets replaced by a 22/23k(previous version) cfgmgr32.dll. This file is present in the MDAC25/Virtual Machine/DCOM(more?) merge modules. This file is not listed individually in my list of files to install, so it is being placed automatically by something. I have created a brand new install without any of the MMs to see what happens, saved, and it worked. So I added the MMs back one by one, saving, building, installing(on a fresh image). No problems! Save, Close, (cuss)Go Home. Now the next day, I add an empty folder to this working install, save, build, install-...NOW THE CFGMGR32.DLL IS BEING REPLACED AGAIN!!!!!!!!!!!!!!!

I went through this same routine last week, but thought it was my fault some how. I've created another install without MDAC25mm at all, and it worked fine until I opened Express to modify the install again.

This file is being replaced after the last reboot between the "...Please wait while Setup configures your system" dos message, and the login prompt, so I don't really have any way to get around it manually.

The Installer computer is WIN98/VB/InstallShield Express 3.1
The installee computer is WIN98(No Windows installer, No MDAC):mad:

Chandima
11-27-2001, 11:56 AM
This file is not being installed by MDAC. I checked the release manifest of MDAC to verify. Could you list the merge modules you are including in your setup? Also I am suprised this happens on a Win98 machine. It would be understandable if it happend on a Win2K or WinMe machine because of System File Protection.

Variable
11-27-2001, 12:16 PM
Comm Ctl 2 (mscomct2), component cat man(comcat), OLE2.4(oleaut32), Tabctl32(tabctl32), vbvirtualMachine(msvbvm60), Comm Ctl(mscomctl)

What about a bad MSVCRT40.DLL?

Chandima
11-28-2001, 08:59 AM
This file is not included in any of the merge modules you mentioned. Do you do a VB scan or a static scan of your project? Any third party modules in your project? Do an uncompressed build and look in the release folder. See if this file is actually added to the setup.

Variable
11-28-2001, 10:32 AM
Stop everything! This is not your fault, InstallShield Express people! Allow me to chow down on some "humble pie"...
USER ERROR: It occurred to me that I was firing off an exe at the end of the set up. Specifically it was an COM+/MTS redistributable file(From my boss). After researching (again?) I found that this exe was placing the cfgmgr32.dll onto the computer(It was origionally designed for NT only). Although I thought I had ruled this out already, I was wrong. So everytime I thought life was good, I would slap that exe in there and go home. I blew almost two weeks because I was chasing the wrong idea. I almost made it through the whole year without making a single mistake...

Almost Humbled,
Variable

Chandima
11-28-2001, 03:30 PM
Glad you figured out the problem!