PDA

View Full Version : Crystal 10 object not loaded on top of 8.5 app.



lchrisenberry
08-06-2004, 04:34 PM
Not making much progress with trying to get a new release out with InstallShield 10 and Crystal 10 and guess what - the deadline is next week. I started out trying to use the Crystal 10 Merge Modules but for some reason the install didn't execute the Crystal 10 install. I could run it separately via the .msi file created but that wasn't desirable. So then I thought I would just create a Crystal 10 object, include it with my application .ism and it would be installed just as I had done with my InstallShield 6.3.1 and Crystal 8.5 install. I thought I had done this fine. New installs loaded Crystal 10 to its new folder, reports ran fine. Upgrades worked fine but now I find out it only works if Crystal 10 was already loaded on the workstation. What happens on a pc where app with Crystal 8.5 has been loaded is that the Crystal 10 objects are never loaded down. Now this is even though I have indicated "Yes" in Include in Build. Do I need to say "YES, PLEASE"! I even changed my Crystal overwrite to be done "Always". but no matter what I do, InstallShield NEVER even tries to install any of the Crystal files. I even tried unregistering the Crystal 8.5 objects before running the install but that doesn't work either. I so wanted to make InstallShield my best friend, but I can see know that is not possible!!! Please help!!!

Much thanks,
Lorraine