PDA

View Full Version : Error 6003 during uninstall



cbermar
08-04-2004, 07:28 AM
Hello,

I have imported an old 6.3 project in X Premier and all seems to be fine. Its a multilanguage setup (english and swedish), uncompressed, which just calls 3 other setup.exe with LaunchAppAndWait. All goes fine, all programs installs and everything seems to work. But when i try to uninstall the main program imported from 6.3, i get the error 6003.

This is the KB page on www.installshield.com: http://support.installshield.com/kb/view.a...%3CATT:EMAIL_ID

After reading this entry, im sure its not cause 1 or 2 since the data1.hdr file is in place as well as user installing has admin privs. But cause 3 made me think, because looking in the professional engine install folder, the setup.dll is 0 bytes in size. But why? User had admin privilegies, no errors during setup. Why is this file 0 bytes?

This happens on XP, 2000 and 98 FE platforms.

If anyone stumbled upon anything similar, please let me know.

Regards,
Christer Bermar

msacarny
08-09-2004, 10:05 AM
I get the same error on W2K when I select the Change or Remove buttons in Add\Remove Programs. I converted my project from IS 7.1 to IS X (InstallScript.) It is ok until I apply SP1, then I get this problem. If I run setup.exe from the install folder, and then Cancel the reinstall, the Change and Remove buttons then work again.

I hope IS can fix this, soon.