PDA

View Full Version : prompting to me uninstall after installing application and restarting my system



pvschandu
07-29-2004, 09:15 AM
Hi

I have created an installshield setup for my application. I could install my application with out anyproblems. I get finsihed message too after installtion. But if I restart my system It immdiately prompts me to uninstall the application which i have installed. What could be the reason. This is message I get after restart.

Are you sure you want to uninstall completly .. and its components.

Pls help me to resolve this issue,

thanks in advance

Liu Song
07-29-2004, 10:35 PM
Hmm, first, Did you do anything after rebooted in your scripts or custom actions? Suppose LaunchAppAndWait?
If not. Check your sequences and those conditions.
Good Luck! I think the most possible cause of this problem maybe your misdoing.:p

pvschandu
07-30-2004, 05:16 AM
There are no custom actions or actions in rebooted section. But I am using LAunchAndWait methods while installing.

Glytzhkof
07-30-2004, 06:00 AM
I'd check HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\RunOnce

and

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\RunOnceEx

What special things have you done in your setup? What custom actions do you have? Why do you reboot? Do you use advertised shortcuts?

pvschandu
07-30-2004, 07:19 AM
Under what circumstances does it automatically intiate uninstall process? Cud you please let me know

Thanks

pvschandu
07-30-2004, 07:24 AM
I am not doing any special action except registering some com dlls and .net dlls using LaunchAndWait method. Apart from this I am not doing any special actions.

It does not prompt me to restart my machine. But If I restart It immdltiately starts uninstall process. Reason I could not find.

I have checked Run and RunOnce. both do not have any default values.