PDA

View Full Version : MDAC - to distribute or not



sandshot
11-15-2001, 07:49 PM
The situation: I released a program a year ago that required MDAC 2.5SP1 or
greater. Of course there was no greater at the time. I conciously chose not
to distribute the MDAC or merge module at the time based on file size. I
merely pointed them to the Microsoft site to obtain it as required. This
worked great until a couple of months ago when I had a couple of reports in
France and Italy of an error finding the required Access database. The
database was there of course. I divined they were all running MDAC 2.6.
Attempts to reinstall MDAC 2.5SP1 on top of it, either via a direct install
of the MDAC or through the installation program, failed and we could never
clear the error. Until that is I sent them a special version of the
installation which included the MDAC merge module. In the last month the
issue has spread to North America. The good news is the debug file is now in
English :) The bad news is it only confirmed the problem that the database
opening routine with a perfectly valid connection string bombed.

Now reading through the group there are a lot of concerns about the MDAC
merge module. I only have one data point and it was good. I'm just looking
for others opinions on how to distribute this.

Of course if anybody has a clue why MDAC 2.6 isn't working (it does on my
Win98SE and Win2k test boxes) I love to hear that too.

Thanks,

Rick

Chandima
11-16-2001, 10:14 AM
Are you aware that MDAC 2.6 (unlike 2.5) does NOT distribute any Jet drivers? Since your problem is with Access and stuff I assume the lack of Jet drivers maybe causing the problem. Please see http://support.microsoft.com/support/kb/articles/Q271/9/08.ASP for more details.

sandshot
11-16-2001, 05:14 PM
I am very aware Microsoft left these drivers out. That was the first thing we tried for the fix. I'm sorry to say, it didn't work.

Thanks,

Rick