PDA

View Full Version : Merge Module Holder Object



helmut
07-20-2004, 03:26 AM
I'm working on an InstallScript Project and want to include some merge modules, for example Microsoft GDI+. When I drag the object (merge module) in the object view and drop it on the feature where I want the object to be inserted, I get an error message "The object Merge Module Holder Object could not be inserted, you may need to reinstall the object in order to use it".

Well, how can I reinstall the object? I've installed InstallShield X several times and nothing changes. And if I would know how to reinstall the object, would it help?

Maybe the Merge Module Holder Object is not included in InstallShield X Professional. Where can I get it if it's not included? And why is it possibly not included?

Thanks for your help!

rsaugier
07-21-2004, 04:17 AM
I got exactly the same error in DevStudio 9 with a custom object I developped. I've spent hours on this, trying to re-register my object, but it doesn't change anything and I've already skipped my deadline...

See my previous post long ago:
http://community.installshield.com/showthread.php?threadid=134660

(Hopefully I had other things to do meanwhile...)

Thanks in advance for any help/comments,

Rodolphe

esiemiat
07-22-2004, 05:14 PM
I called support on this a few days ago and they said they never heard of this. I ended up having to reinstall InstallShield which fixed the problem. Perhaps someone in development will take a look at this now more of us have experienced it.

helmut
07-23-2004, 01:13 AM
I reinstalled InstallShield X several times, but the problem remains. I'm tired from installing and uninstalling the product.
:confused:

rsaugier
07-23-2004, 08:23 AM
As for me I solved the problem by reinstalling InstallShield DevStudio 9
incl. sp1 on a different, fresh system (and without applying any patches).

The problem seemed to have something to do with what lies in:

C:\Program Files\Fichiers Communs\InstallShield\Professional\RunTime\09

There are two subdirectories there, for each minor version of IS (00 and 01)
These subdirs contain, among other things, ctor.dll which appeared in
the error message dialog box I had when trying to modify the Objects which
were already included in my project.

Somehow the 01 subdir was missing on my computer, and this was causing a conflict.

rmccollam
07-23-2004, 12:15 PM
I too was having this problem. But installing SP1 (which seems to have come out today) fixed it for me.

Dehga_
07-19-2005, 09:04 AM
I got exactly the same error in DevStudio 9 with a custom object I developped. I've spent hours on this, trying to re-register my object, but it doesn't change anything and I've already skipped my deadline...


Me too, with IS 10.5! My own object (created in 7.01). :mad:

There is no help for it, no useful information on the message box.

I hope they get the message and fix this.