PDA

View Full Version : Splash screen popups before the application starts



saharey
07-13-2004, 06:18 AM
Hi All,
I have created multiplatform installers for our java based application, my installshiledX genrates installation for Linux and windows by the names win32.exe and lin.bin files respectively.
After double clicking on win32.exe file my application get installed on windows2000 professional os.
The problem is that when i run my application by double clicking on the icon created on desktop say 'DogBit', it flases a InstallShieldX splash screen with message 'Initilizing the application' before my applications splash screen, i want to remove this splash screen but unable to find the way.
Can anybody help me out in resolving this problem i will be thankful to him.

wishes
pritesh

brianl
07-16-2004, 11:54 AM
Hi,

Are you using IS X? The behavior you should be seeing after you double-click the launcher (.exe file) is:

1) The "Preparing the InstallShield Wizard..." dialog appears, then goes away.
2) Your splash image appears, and is present on the screen for the number of seconds that you specify, then it goes away.
3) The "Initializing Wizard" screen appears briefly, then disappears.
4) The Welcome panel appears.

There is no way to turn off the "Initializing Wizard" screen, but it should not be appearing over your splash screen.

saharey
07-19-2004, 06:16 AM
Hi Brain,
Thak you for your support, actully the process goes like this.

1)I created 'Win32.exe' file for java application using InstallShieldX
2)Double clicked on 'Win32.exe' file to install the application on win2000 professional os.
3)java application get installed along with creating a desktop icon for java application named "DogBit"
4)Double click on this desktop icon "DogBit" to launch the application, as soon as i double click on this desktop icon a dilaog splash with message "Initalizing install shield wizard", this dilaog splashes for a very few seconds and than our orignal splash screen flashes.

So i want to remove this Image or Dilaog which is coming before my application's orignal Splash Screen comes.

can this be removed?now i think i am more clear to you, can you provide some feedback on this issue.

thanks
saharey

brianl
07-19-2004, 11:17 AM
If you are speaking of this dialog (see attachment), you can disable this dialog from appearing with your win32 launcher by passing in "-is:silent" as an argument with the desktop icon. To do this, specify "-is:silent" under Advanced Properties-->Args for the shortcut in your project.

saharey
07-20-2004, 01:36 AM
Brian thank you very much it worked, i am very much thankful to you.

wishes
saharey