PDA

View Full Version : web deploy setup.exe failure



rlafleur
11-08-2001, 03:15 PM
Using 3.51 and building a Web Deployment using the option of 'Traditional Save or Run'

"SOME" users can use the single setup.exe that is downloaded. Others get "This program is unable to run in Dos mode"

I can not find anything like it in the knowledge base. It works on my machine(s) but I've had too many failures by end users with the same error.

Chandima
11-08-2001, 04:47 PM
:confused:

We use pretty much the same technology in the Developer 7 Web Installs too but I have never even heard of this!

I need more info on this to try and reproduce it. Do you have contact with any of the customers? The best thing would be to get an installation log of this.

Ask someone to download the file and then from the command line type (after browsing to that location)

Setup.exe /v"/lv C:\TestLog.txt"

Ask them to send you this log file and you send it to me (chandimar@installshield.com).

Is there any particular Operating System or version of Internet Explorer or Netscape that this is failing on? Any detail would go a long way to help narrow this down and figure this out. Thanks.

rlafleur
11-14-2001, 08:47 AM
The program never gets to the point where it can create a log. It fails immediately.
I am using Installshield Express 3.51, Web Deployment, Traditional Save or Run for both IE and Netscape. I am including the MSI engines.

:confused:
I also tried a single image and sent that setup.exe file to the server. Same results. The file fails to expand.

Chandima
11-14-2001, 12:12 PM
The only thing I can think of is it being a machine specific issue. Do you know the system configurations of the machines this fails on?

Stuff like:

Operating System
Internet Explorer Version

Brainstorm! The install not getting far enough to log means the Windows Installer is not activated. Are these machines by ANY REMOTE chance Win98 systems that do not have the Windows Installer already installed? You can check this by asking them to do a search for msi.dll.

If this is the case it's a variation of a problem a number of other users have experienced. Manually installing the engine (running instmsia.exe) fixes the problem. On member of this baord said that this issue seems to have been fixed with the msi 2.0 engine.

rlafleur
11-14-2001, 01:54 PM
I duplicated it at work!
I have two machines - 2000 pro and XP Pro.
The xp pro is for testing and ONLY has XP, Acrobat Reader and a printer installed. ALL else is standard from the setup.

I am on a network.

1) Running WindowsXP Pro.
2) Created webdeployment - 'traditional save or run options'
3) Both ie & netscape
4) Both MSI engines
5) Download MSI from Web = yes

From the XP machine, I copied the setup.exe file to my desktop, and it works.

I then downloaded the one from the web and got something a little different!

When looking at the properties in XP from the copied setup.exe and the downloaded one they are different.

bytes
a) Downloaded: 30,801,920 bytes
b) Copied: 30,801,920 bytes

Type:
a) download: Application
b) Copies: Application

Description
a) Downloaded: setup <-------------------
b) Copied: Setup Launcher

The ICON
a) Downloaded: looks like a square window (dos)
b) Copied: Looks like a Setup Icon with computer and a box of diskettes.

The properties window in XP is completely different when either is right clicked:
Downloaded tabs: General, Program, Font, Memory, Screen, Misc and Compatibility (Dos!)

Copied tabs: General, Version, Compatibility

:eek:

Thoughts?

Robert

Chandima
11-14-2001, 03:16 PM
I actually just got some feedback on this issue from a Developer. Just like you have found out, he says that this error usually comes if there was an error while downloading the file. He suggested doing a binary diff (comparing files on a binary level) of the downloaded Setup.exe and Original one you built.

It's pretty obvious there is something different though because the icons should be the same. I'm afraid it looks like an error occuring during the download.

Does this files get downloaded in this corrupted format every time?

rlafleur
11-14-2001, 03:34 PM
I've had several people tell me it has worked. I tried it myself and it failed. I also tried skipping the html file Installshield builds, and entering mywebsite.com/setup.exe

This brought up a dialog box to 'save as:'
I saved to my HD and it failed.

Installshield used to have a web deployment that broke up the download into chunks. Is it not possible to use that one?
I still have all my old CD's. As I recall it broke it into 128k chunks. and would restart where left off if the download failed in the middle.

Wouldn't that version still work? and if so, can you tell me which version it was?

Chandima
11-15-2001, 02:12 PM
Was it a older Express version (2.x) or an InstallShield Professional version? I really am not familiar with either of these. Only problem with that would be that you will have to redo your project in that version because they don't use the Windows Installer and the project itself is not backward compatible.

rlafleur
11-15-2001, 02:31 PM
I think I've found the problem. My ftp software is set to upload in auto-ascii mode. I think this started to hic-cup and send in ascii mode instead of binary.

I downloaded a newer copy of the ftp software and tried it again.
Ftp upload, then used my browser to connect to the web page IE Express created, downloaded and saved.

So far, based on three successes, it is working.

Thank you for your support. It is appreciated.
Robert