PDA

View Full Version : Advertised Shortcut installs but does not launch exe.



anklboyy
07-08-2004, 03:07 PM
I have an installation that handles advertised shortcuts for a few merge modules. On windows 98 (IE5.0) all the advertised shortcuts, when clicked the first time, install the files but do not continue as expected to launch the application. You have to launch the shortcut a second time (install state would be local by this time) to get the application executable/Key file to launch.

When tested on windows 2000 and XP the executable is launched with the first click of the Advertised shortcut after the files are installed. There is a registry "ResolveIOD" value which did not help this situation.

Help! Suggestions... Anyone?

Mariapr
07-09-2004, 03:18 AM
hi. We have also met this problem- as far as i understand it is a "feature" of Win9x. I didn't find any better way then to demand a reboot after installation on win9x. :((
sometimes it is not convinient. if you find another solution - it will be very useful...

anklboyy
07-09-2004, 10:56 AM
My understanding is the reboot is required for the first installation and without rebooting the advertised shortcut would not know to initiate the "install-on-demand". The problem I am seeing is after the first "advertised" installation and reboot. On a 98 advertised shortcut after the "install-on-demand" is initiated and its application files are installed it does not launch the application. Windows 2000 and XP however do launch the application as expected.