PDA

View Full Version : msvci70.dll not found after setup



jrwade
10-31-2001, 04:15 PM
I am running InstallShield Express 3.03 Limited Edition that came with Microsoft Visual FoxPro 7.0. I prepare, build and create distribution files according to the instructions given. I run the setup file, everything appears to run nomally. I get the final dialog that says that the installation was successful.
When I run the application, I get the message that the required dll "msvci70.dll" is missing. This is the c++ runtime that is shipped with the product and located in the file :\WINDOWS\SYSTEM on a Windows 9X machine.
This same thing happens when I setup and run on any machine. On my development machine (Windows 2000) it does not have a problem. I suppose that is due to the fact that this is where I have Visual FoxPro 7.0 installed so runtimes are already there and registered.
The file is located in that directory but does not seem to be registered. The install dialog does provide a message that it is registering the product during the install.
I can't seem to locate the problem or resolve it. Any help would be appreciated. Thanks in advance.
James

Chandima
11-01-2001, 09:40 AM
Are you sure you got the file name ("msvci70.dll") right? I did a search on the microsoft DLL database and it didn't find it. Further I tried on MSDN and it didn't have a single article! So I assume there is a typo here :)

Are you aware of any Visual Foxpro runtime files, or somehwere I can get some information from. Thinking maybe we should create a merge module that distributes these runtime files.

jrwade
11-01-2001, 10:26 AM
Yes, I did get the file name right. To confirm, it is named "msvci70.dll." After the build, this file is located in the Win\System folder. A Word document file distributed on the FoxPro 7.0 disk named "vfpdeploy.doc" in the folder "Technical Articles" instructs us under the subheading "Selecting Objects/Merge Modules" to [begin quote]"select the Microsoft Visual FoxPro 7.0 Runtime Libraries and the Microsoft Visual C++ 7.0 Runtime Library if you are installing a Visual FoxPro application.
Note The Visual C++ 7.0 Runtime Library is required by Visual FoxPro 7.0" [end quote].
After the build in InstallShield Express (v. 3.03) Visual FoxPro Limited Edition, the three Visual FoxPro 7.0 runtime library files are found in the folders "Program Files\Common Files\Microsoft Shared\VFP" and are named: "vfp7r.dll" "vfp7renu.dll" "vfp7t.dll."
As one would expect Microsoft disclaims any support of the InstallShield product even though we paid for and expect to get the deployment capability we had in VFP 6.0.
I have two applications ready for deployment in our prosecutors office and six more that I will have ready in the next two weeks. These apps work fine as long as I run them on my machine. That's not very helpful for application development. It does surprise me that the Windows Installers (instmsia and instmsiw)that are provided with the build don't properly register the dlls.
The dlls are placed in the appropriate directories.
Is there anything else you need to have in order to try to help me? Is no one else having the problem? Or is the use of VFP 7.0 still so limited. If no one else is having the problem what am I doing wrong? Thanks in advance.
James:confused:

jrwade
11-01-2001, 11:00 AM
I just tried the installation on a Windows 2K machine and to my surprise I got a different message when I ran the installed application. This time the message said it could find the required dll "msvcr70.dll" in (my search path). I copied the dll of that name and to the WINNT\SYSTEM folder from the Visual FoxPro 7.0 disk and the application ran fine. I will install this dll on the Windows 98 machine and see if the app runs
James

jrwade
11-01-2001, 12:55 PM
Well, who knows what gives with this matter. I installed the applications in question on a Windows 98 machine from CD and got the message stating that it was missing "msvcr70.dll" I installed another VFP 7.0 app from the server and got the same message. There is no "msvcr70.dll" among the distribution disk files. Both the "msvcr70.dll" and "msvci70.dll" files are on the VFP 7.0 disk in the folder \WIN\SYSTEM. After copying the file "msvcr70.dll" to the SYSTEM directory on the computers where the apps are installed they ran properly.
Could the merge file process be putting the wrong dll in the distribution folder \win\system or am I doing something wrong in configuring the InstallShield build? Is the vfpdeploy.doc article incorrect on the VFP 7.0 disk in the \Techinical Documents folder?
Could the checkbox for the Microsoft Visual C++ 7.0 library be mapped to the wrong file? Please give me your thoughts. I can replace the msvci70.dll file with the msvcr70.dll in the \win\system folder before creating the distribution as a work around in the mean time.
James

jrwade
11-01-2001, 01:05 PM
:o Well, I just went back to InstallShield and check the listing of Merge Modules. I must have been asleep. I will check all _three_ Visual C++ 7.0 Runtime Library boxes. I had only checked one. The document on the FoxPro disk vfpdeploy.doc does not indicate that there are three of these. The missing one was not checked on my previous builds. The only one I had checked was the one for the msvci70.dll. Don't know why I got the message that it was missing. Maybe I just went to the CD I created to see what was there because the message was already gone even thought I wrote it down. Maybe I thouht I had misread the message. Sorry for the confusion!
James

Chandima
11-02-2001, 09:47 AM
I am glad you got it figured out!! I was getting a bit nervous thinking we had big problems with Visual Fox Pro files!! Thanks for posting a reply saying you found what the problem was otherwise I would be driving myself nuts trying to figure out a way around it :)