PDA

View Full Version : Problem with Skinable dialogs



Tony Dixon
06-25-2004, 05:15 AM
I have a problem with skinable dialogs. my install use these dialogs and all was well, but then the background colour and images whent missing.

when i log i find the following

Action ended 11:10:35: SetupProgress. Return value 0.
Action start 11:10:35: ISSetupFilesCleanup.
1: Standard project type, let scripting engine clean up setup files...skipping action
Action ended 11:10:35: ISSetupFilesCleanup. Return value 1.
1: Not using skins for this installation. Could not find skin file C:\DOCUME~1\PCITPD\LOCALS~1\Temp\_is25B\setup.isn.
1: Ready to launch program block.

the skin file is missing why does any one know?
:confused:

helmut
07-20-2004, 07:46 AM
I'm not sure if I can help you. But I had similar problems. I selected a custom skin in the "User Interface/Dialogs" section of the view list (left side of the screen). But it doesn't work.

Now I select my custom skin in the media wizard dialog. And now the skin is working fine.

Well, maybe just another bug in InstallShield X. I discontinued counting the bugs :-(

Tony Dixon
07-20-2004, 07:51 AM
Yes it another bug..:mad:

the skin file that is created when you use skinable dialogs is not included in the list of the file that are compressed.

so if you select in the build options "signal exe" the skinable dialogs are gray.

this is a known bug the work around is to use the compressforeweb tool off the installshield site.

or use the cab or web settings.

i have reported this and there is a work order in place for it. hopfuly it will be fixed in the next service pack.

:confused: