PDA

View Full Version : Compiling InstallScript



slipitinterry
06-22-2004, 07:23 PM
I have a brand new IS X InstallScript MSI project.

After adding a few files, I attempt to build the project, and find that it cannot stream setup.inx into the binary table. After checking the project directory, I see that setup.inx doesn't exist.

When I attempt to Compile the Installscript, nothing happens. I have tried a right-click and seleced Compile, when the setup.rul is selected, and I've tried the compile button on the toolbar.

Any ideas why this won't work?

I've tried rebooting my machine, thinking that I had too many things running, but that didn't help.

Thanks
--Terry
:confused:

MichaelU
06-23-2004, 10:25 AM
If you don't even get compile errors, see if this thread (http://community.installshield.com/showthread.php?threadid=130968) addresses the issue.

Michael

slipitinterry
06-23-2004, 12:54 PM
Michael,

Thanks for the response. Those are the exact symptoms that I experience. However, I can't find any similar culprit file that could be blocking access to the "\Program Files", or "\Program Files\Common Files" directories.

I have the main Installshield X prorgam files installed to "e:\devtools\Installshield X", and there's nothing even close along that path, which could be confused.

Any other ideas?

Thanks.
--Terry

MichaelU
06-23-2004, 02:15 PM
Do you have other InstallShield tools in e:\devtools? Perhaps a directory like e:\devtools\InstallShield\DevStudio 9?

If that's not it, then I'm out of ideas. I was really lucky that Paul found the source of the one scenario.

slipitinterry
06-23-2004, 02:48 PM
DevStudio 9 was installed to e:\Program Files\Installshield\DevStudio9.

After I uninstalled that, since I don't really need it, Installshield X won't even load my project anymore. ;-(

I'll reinstall X and see what happens with that.

Off to find the IT guys...

--Terry

slipitinterry
06-23-2004, 04:32 PM
I ended up uninstalling DevStudio 9, and InstallShield X, then re-installing InstallShield X.

Now everything is working again.

Thanks for the comments.

--Terry