PDA

View Full Version : Error 1311 / CAB file



Scytec01
06-18-2004, 09:50 AM
I am having a problem with a basic MSI install.

The project requirements require the data to be provided in a CAB format – with an MSI file external to the CAB. By changing the setting within the Release Wizard to Media Type CD-ROM I was able to get the file structure I was looking for.

However when I try to install the package on another computer I get the following error message: Error 1311. Source file not found: C:\WINNT|Downloaded Installations\{#}\ Data1.CAB. Verify that the file exists, and that you can access it.

I believe that the user computer is not able to access the contents of the CAB file; and since Setup and the MSI are external to the CAB the install simply fails.

Do I need to include a Merge Module or some other type of scripting in order for the user computer to be able to access the CAB file and complete the install?

Or am I completely off base and need to use another approach?

RobertDickau
06-21-2004, 09:32 AM
No, you shouldn't need to do anything special for that media layout. Does the issue described in this Microsoft KB article apply: http://support.microsoft.com/default.aspx?scid=kb;en-us;325076?

Scytec01
06-21-2004, 09:53 AM
Thanks for the response but I don't think it applies to my situation because I am logged on as an administrator and have full access.

Jeff

chmose
06-21-2004, 01:10 PM
I'm getting the same thing with installshield 9 devstudio. Things work fine doing a network install and creating just 1 single setup.exe but using the cd-rom type I get the exact same error. Also logged in as system admin and verified that the cd-rom restriction is not in place.

Jessica Zhang
09-01-2004, 03:59 PM
I get same error message (Error 1311. Source file not found: C:\WINNT|Downloaded Installations\{#}\ Data1.CAB.) with InstallShieldX. When I copied Data1.cab from media folder to this Downloaded folder with Retry, it go through the installation.
Is this file should be copied by InstallShield? Or I need have some settings done when build the Media?

Scytec01
09-01-2004, 04:43 PM
I was able to fix this error by adding a single key file to each of the directories present in my project. When I initially added the files to my Basic MSI project there were a few directories that did not have a key file.

I am still an Installshield X newbie so I cannot tell you specifically what the key file does, only that once I added at least one to each directory in my project that it compiled and worked as advertised.

I added the key files using the Installation Designer\ Application Data\ Files and Folders\ Destination Computer & right clicking on one of the files.

I hope this helps.

Jeff

rsknowles
04-08-2005, 03:23 PM
I have experienced this issue in two different Basic MSI projects. The key file suggestion did not work for me. The only thing that worked was changing the Release type to a Network Image so that the output was a single Setup.exe. When this is done the Cache Web Download setting caches the entire Setup.exe in Downloaded Installations.

When the release type is CD, only the MSI file is cached even though there is a Setup.exe, an MSI file, and a CAB file.

I would greatly prefer to use CD types but it doesn't look like its possible and I have heard of no possible fix.

djones77
04-13-2005, 01:53 PM
Sup all,

I have almost the same issue. I have run this down to the OS the destination system is running. (In my case the install is created and burnt on XP) If the destination system is 2000 the install fails with the same error seen above. I have verified my issue is not related to the SW used to burn the CD or the format of the CD. Is this the same situation you are having? BTW I am stumped on it myself.

djones77
04-13-2005, 02:37 PM
What OS is the install created on and what OS is the target system running? I have something like this going on myself.

ihayesjr
04-13-2005, 03:17 PM
I am having the same problem also. I am using InstallShield DevStudio 9 with a Basic MSI Project. I made the install only for Windows NT/2000 only and still get the error.

grantmi
03-27-2006, 11:05 AM
In the Releases view, if you have chosen CD-ROM as your media format, then setting the Cache Web Download setting to Yes will give you the Error 1311.Source file not found: ...Data1.cab.

So to get rid of the error just set Cache Web Download to No. (But then your installation will not be cached on the target system)

If you want to cache your installation on the target system. It seems the easy way to do this is create a new release media "Network Image" and choose a single setup.exe. Then you can set the Cache Web Download setting to Yes and it caches all the data you need.

dlphillips
09-05-2007, 09:57 PM
This error is caused by selecting the "Cache MSI Locally" option in the install build. It is supposed to work, as a cached package supports advertisement and repair without the original media, but when your CAB file is outside the MSI, it does not work. The problem is the CAB file has not been moved into the cache location with the MSI file by the install engine.

Turn of this option for your release build and the install will work.

Frustrating isn't it. This should work, as there is no reason why a CDRom media insall package can't be cache'd locally. This used to work way back in Install Shield 8, but like most useful features, it doesn't work any more.