PDA

View Full Version : Depending on MSXML 4.0 or higher ...



peterbi
06-15-2004, 08:02 PM
Hi,

My new package need to depend on MSXML 4.0 or higher, what's the best way to set the dependency?

Thanks,
Peter

_doog_
06-17-2004, 05:56 AM
best way would be to include the xml4 merge module into your package

peterbi
06-18-2004, 11:11 AM
Well, it's best if we can make it more flexable - not only xml4, if we include a merg module, what if there are xml5 and xml6 in the future?

I think there must be a way to get the information on what version of xml the system has, that's what I want...

Thanks for your advice anyway ...

Peter

_doog_
06-21-2004, 05:17 AM
xml is always installed side-by-side, so if you need a specific version, it would not help to install the latest version...

as it is installed side-by-side, there are dll's for every xml-version, so you could not just simply check one file.

if you really want the latest version, you would have to check the activex registration for msxml2.domdocument, you will find a pointer there to the latest version (though i can not really see what the effect determining the latest version is, shipping with the version your application was created should do a better job)