PDA

View Full Version : Custom Action problem



nostra
06-13-2004, 12:58 PM
sorry for my bat english, my mother tongue is german :o

I have problem with custom action.
I want run a *.exe file from installdir, after that setup is finish.
here my settings

program file key: *.exe
command line: [INSTALLDIR]*.exe
return processing: asynchron (wait of exit code)
else nothing.

but *.exe starts not.

now have I under Execution Sequence Install: After InstallFinalize adjusted.
now starts *.exe at end from setup.
setup stays but hang. I must first kill the *.exe and now appears end from setup, where can click complete button.

what must I do, therewith *.exe first starts when I click the complete button?

thanks for help

RobertDickau
06-14-2004, 06:52 PM
For Return Processing, perhaps try Asynchronous (no wait for completion)?

nostra
06-15-2004, 04:51 AM
Originally posted by RobertDickau
For Return Processing, perhaps try Asynchronous (no wait for completion)?

thanks for you replay response.
but all already attempted, without success.

I use now the wizard and now flips.
the wizard make this similarly as I, respectively as you propose.

program file key: *.exe
command line: [INSTALLDIR]*.exe
return processing: asynchron (no wait for completion)
else nothing.

only denominate he the action differently.

IS_LAUNCH_MY_PROGRAM_PLEASE

vadimk
06-15-2004, 05:04 PM
you need to put a correct file key in the executable file key area. This has to come from the File table.
Try using a MSI type 34 custom action (Path Referencing a Directory). You can chose the working directory as INSTALLDIR and type anything you want on the command line so try *.exe

If this doesn't work try writing a installscript or vb/jscript to do what you want.