PDA

View Full Version : Must upgrade *.ism file Dev 7 Sp4 to Dev 7.02???



CarloD
06-11-2004, 12:09 PM
Hi,

I'm trying to open a .ism project created in IS Dev 7 Sp4. When I open the project in IS Dev 7.02 it says the project was created in an older version of IS and must be upgraded. Then when I try to upgrade it I get errors:

Upgrading table Property
** Error: 1011: Unable to insert record.
Property
** Error: 1011: Unable to insert record.
Property

After that it SEEMS to work okay, but I don't want to have to upgrade the project. I actually want to build the project from the command line using ISCMDBLD. When I try to build the ORIGINAL project with ISCMDBLD I get the same errors and it just upgrades the project but doesn't build it.

So my question is what's going on? Do I REALLY need to upgrade a project from 7sp4 to 7.02? This seems incredible to me.

Any help would be greatly appreciated. I'm trying to put together a script to build this application and the installshield command line build is causing me no end of grief.

Thanks,

Carlo:confused:

huntant
06-14-2004, 08:44 AM
The message you are getting is just a default when ISD detects a different version. 7.02 won't open a 7.04 project, new tables were added that 7.02 can't understand. You will need to upgrade your build machine to 7.04 and your automated build script should start to work.



Anthony