PDA

View Full Version : Patch doesn't work -> 1729 Configuration failed



bonovox
06-11-2004, 02:43 AM
Hi !

My patch doesn't work !

Please have a look at my log ...
=============================================
...
Property(C): ServicePackLevelMinor = 0
Property(C): UILevel = 5
Property(C): Privileged = 1
Property(C): QFEUpgrade = 2
Property(C): MsiNTProductType = 1
Property(C): ACTION = INSTALL
=== Protokollierung beendet: 09.06.2004 18:24:57 ===
MSI (c) (84:70): Note: 1: 1729
MSI (c) (84:70): Produkt: JET Ticket Professional -- Die Konfiguration ist fehlgeschlagen.

MSI (c) (84:70): Attempting to delete file C:\WINNT\TEMP\1a1d50.msp
MSI (c) (84:70): Grabbed execution mutex.
MSI (c) (84:70): Cleaning up uninstalled install packages, if any exist
MSI (c) (84:70): MainEngineThread is returning 1603
=== Verbose logging stopped: 09.06.2004 18:24:58 ===

=============================================

I'm using Basic Setup Type!
Starting my patch like this ...
msiexec /p JTPUpdate360sp5.msp REINSTALL=All REINSTALLMODE=omus /qr

But:
The user that runs the patch doesn't have administrative rights. So we are using a little prog that starts the patch using "CreateProcessWithLogon"-Api-Call (with the local administrator account).
I don't know if this info is important, because a lot of our users are using this feature without any problems!

thx, Bono

bonovox
06-18-2004, 01:53 AM
Nobody got an idea?

Peter Kosenko
12-10-2004, 06:35 PM
I am getting this same 1729 configuration error in the verbose log, and a feature transfer error 1603 in the user interface.

Do you now know what was causing it?

My situation is that release 2 (INSTALLLEVEL 2) upgrades release 1 (INSTALLLEVEL 1) adding in new components during minor upgrade. Basically, if we given them release 2 after release 1, INSTALLLEVEL is bumped up to 2 and they get extra features.

Everything is the same in each package of the installer (same feature tree in the MSI databse and everything is in the cab files) except the release name and the code invoked by it.

I am not setting REINSTALL ALL. I am letting the InstallScript-MSI installer determine what is and isn't installed and needs upgrading and installing. It seems to me that that should work. ProductState is 5 (if that has any significance -- already installed for user).

In fact, the error seems to come well into the status dialog display, at the end of the installation, after files have moved, although that might just be a latency of the error dialog.

Does anyone have an idea what might be going wrong in such a circumstance?

The verbose log is no more helpful to me that yours below.

Peter Kosenko


Property(C): ACTION = INSTALL
=== Protokollierung beendet: 09.06.2004 18:24:57 ===
MSI (c) (84:70): Note: 1: 1729 <-------------------[SAME HERE]
MSI (c) (84:70): Produkt: JET Ticket Professional -- Die Konfiguration ist fehlgeschlagen.

MSI (c) (84:70): Attempting to delete file C:\WINNT\TEMP\1a1d50.msp
MSI (c) (84:70): Grabbed execution mutex.
MSI (c) (84:70): Cleaning up uninstalled install packages, if any exist
MSI (c) (84:70): MainEngineThread is returning 1603 <------- [SAME HERE]
=== Verbose logging stopped: 09.06.2004 18:24:58 ===[/FONT]

=============================================

I'm using Basic Setup Type!
Starting my patch like this ...
msiexec /p JTPUpdate360sp5.msp REINSTALL=All REINSTALLMODE=omus /qr

But:
The user that runs the patch doesn't have administrative rights. So we are using a little prog that starts the patch using "CreateProcessWithLogon"-Api-Call (with the local administrator account).
I don't know if this info is important, because a lot of our users are using this feature without any problems!

thx, Bono[/QUOTE]

bonovox
12-13-2004, 05:09 AM
sorry ... this only happend once ... and i didn't have the problem again ...
(also i do not use dev7 -basic project- anymore ... now i am using devstudio9 - installscript msi project)

maybe you can find a solution anywhere here ...
http://community.installshield.com/showthread.php?t=94806&highlight=1729
http://community.installshield.com/showthread.php?t=60197&highlight=1729
http://community.installshield.com/showthread.php?t=57057&highlight=1729