PDA

View Full Version : Newbie: The object X could not be inserted, you may need to reinstall the object...



rsaugier
06-04-2004, 11:11 AM
Hi all,

(This is for an InstallScript project in DevStudio 9, if you doubt)

I get this message when trying to add my object in the installation designer, in application data / objects:

The object "MyObject" could not be inserted, you may need to reinstall the object in order to use it.

Of course I tried to reinstall it, that is, to recompile my custom object MyObject with Ctrl-F5. The object is registered successfully, but I still get the error when trying to insert it in my main project.

I never seen this error before, and my object worked perfectly two days ago when this error appeared.

Thanks a lot in advance,

Have a nice day :)

Rodolphe Saugier - Developer

ridout
06-11-2004, 11:58 AM
I get this same error in InstallShield X

Brian

rsaugier
07-23-2004, 08:26 AM
As for me I solved the problem by reinstalling InstallShield DevStudio 9
incl. sp1 on a different, fresh system (and without applying any patches).

The problem seemed to have something to do with what lies in:

C:\Program Files\Fichiers Communs\InstallShield\Professional\RunTime\09

There are two subdirectories there, for each minor version of IS (00 and 01)
These subdirs contain, among other things, ctor.dll which appeared in
the error message dialog box I had when trying to modify the Objects which
were already included in my project.

Somehow the 01 subdir was missing on my computer, and this was causing a conflict.

(Note: this is a copy of my post in the IS X subforum:
http://community.installshield.com/showthread.php?threadid=136493)