PDA

View Full Version : Most IS+MSI installations fails on Windows 2003



lansdale
05-27-2004, 04:02 AM
I didn't know which conference to post this message so I'll post it here since I'm a IS9 DevStudio developer. This is a generic problem and not a developer question.

On our upgraded Windows 2003 server we have not been able to install most MSI+IS installation packages for the last 2 months. I get error "1719". I spent much of the last 2 months scouring the world for information and have attempted all suggested fixes and work-arounds. Nothing has worked, and believe me I've tried almost everything.

Two days ago I brought Microsoft paid support services into the picture. We have spent 9 hours on the phone so far, and another 10 hours of my time thereafter digging around. So far I've stumped the best of their 4-5 people on this problem.

Being an IS and Windows developer I've been digging deep into this problem. Doing a MSI debug on the failing installations points the failure point as the Custom Action invocations. As a trivial example, the IS7 and IS8 "isscript.msi" files fail to install. See below for the snippet of logs which shows the failure point. The IS9 isscript.msi works because it does not have isscript.dll to register, as does the 7 and 8 versions.

--------------------------
MSI (s) (9C:C4): Executing op: InstallProtectedFiles(AllowUI=1)
MSI (s) (9C:C4): Executing op: ActionStart(Name=RegSvr,,)
MSI (s) (9C:C4): Executing op:
CustomActionSchedule(Action=RegSvr,ActionType=3073,Source=BinaryData,Target=RegisterISDriverFiles,)
MSI (s) (9C:34): Invoking remote custom action. DLL:
E:\WINNT\Installer\MSI66.tmp, Entrypoint: RegisterISDriverFiles
MSI (s) (9C:3C): Generating random cookie.
MSI (s) (9C:3C): Created Custom Action Server with PID 2084 (0x824).
MSI (s) (9C:88): Running as a service.
*****>>>>>**** MSI (s) (9C:88): Custom Action Server rejected - Unknown
Process.
--------------------------------

Thus, I've turned my attention to dcomcnfg and COM+. This is all working and the default priviledges have been set up for the Interactive User just as mentioned in the Installshield KB. All servi ces are running properly, all registry and directory priviledges are ok and I've double checked every known "fix" for MSI installer problems a few times over. I'm not coming at this problem fresh, but I (and the Microsoft tech support team) are looking to Installshield Corp to give us some more clues on what is blocking the process invocation from running at the Custom Actions section. Knowing how DCOM handles the out of process task we've been looking to that as a problem source. But we've examined filemon and regmon traces and nothing wrong shows up. Complete system log dumps show nothing wrong either.

I've read all the other postings on the Community site but the suggested fixes for priviledges has not helped or changed anything.

Is there anything that can be suggested to let us move along further on this problem? Thanks.