PDA

View Full Version : Help! - Stuck in a reboot loop - HELP!



cbloom
10-19-2001, 03:39 PM
HELP - ANYONE- PLEASE!

I'm just an end user and there's no support available to me from InstallShield. I installed a program on my computer today that uses InstallShield and something must have gotten messed up somewhere along the line. Now my computer is stuck in an endless reboot loop. Whenever I login everything boots up fine but then I get a window that keeps popping up saying:

Windows Installer -
Preparing to install...

It flashes a few times and then reboots the computer. Even if I press the cancel button on the installer window it still reboots. And actually, I was just watching it and it reboots with out even having to log in.

If I reboot to Safe Mode then I can at least try to debug the problem but so far I've been unsuccesful. I've tried to uninstall and reinstall the program that caused the problem (Flash) but that didn't work. I ran RegClean but that didn't work. I've searched the registry for any instances of RunOnce but no values are defined that refer to any of the InstallShield files (in fact no values are defined at all). I even went so far as to rename the InstallShield directory in the Common Files folder. All that did was stop the flashing Windows Installer window from popping up but it still reboots itself.

Can some one tell me where the computer is getting the reboot directive from? Or is there a way to uninstal the InstallShield end user product from my computer?

Working in safe mode is no fun! HELP!

I'm running Windows 2000 sp2

Thanks,
Chris Bloom

Chandima
10-23-2001, 08:14 AM
It could be that your machine is caught in a loop installing MDAC. That's the only known issue (which is now fixed) that I recall would do something like this. Try this. Log in to your machine in safe mode. Do a search on the machine for "*.msi". On most machines these are located in C:\Windows\Installer, but not sure on 2K.

Try moving this (or these) files to another location on your machine. Then when your machine launches in normal mode Windows Installer should fail because it can't find the msi in the specified path. At least this should let you cancel out of the endless reboot.

Hope this helps.

cbloom
10-23-2001, 08:23 AM
Chandima,

Thanks for the response. I was able to trace the problem (via the event logs) back to Roxio's Adaptec CDRW software. Up until last Friday it was running fine but the botched Flash install seems to have angered it. Roxio and Windows 2000 have known bugs, though so it was probably only a matter of time. Prior to uninstalling the Roxio software I did search my machine for the *.msi files and low and behold there was the Roxio installer.

Thanks for your response!

Regards,
Chris