PDA

View Full Version : Error 2763 while Removing Backup Files



Philip Mackey
05-25-2004, 03:08 AM
I am getting an a 2763 error followed by a 1603 error when the installation get to the Removing Backup Files.

I did a logged installation, attached, and tracked the error to the InstallExecute action. However, the log does not indicate what the error is.

Can I tell what has been spooled into the script to be run?

I am lost as how to continue.

Note: I have started using Crystal 9 merge modules, but have tryed removing them from the package and still get the same error.

_doog_
05-25-2004, 08:03 AM
have you validated your setup and removed all ERROR messages?

Philip Mackey
05-25-2004, 10:46 AM
On your advice I validated the package against the full MSI validation suite. This highlighted a few problems (53 error, 105 warnings) - oops!

However, most of the errors are:

"Missing specifications in _Validation Table (or Old Database)"
or
"xxxxxxx is used in an unsupported way. Typelib should be registered via the Typelib table -- this key is automatically written during typelib registration."

Does this indicate any thing?

_doog_
05-25-2004, 10:50 AM
did you use the CR merge module from installshield or that from Crystal?
in my experience with the last set, they are not to use without massive patching with orca. The merge modules from installshield do work quite fine - there are 3 KB-Articles on how to use them

you need to concentrate on the ERROR message (you could ignore the warnings in first place) - but the ERRORS have to be fixed.

look at the ICE27, that is the cause for your error.

Philip Mackey
05-26-2004, 05:09 AM
Thanks for the pointer. Fixed some of the error down to 20 errors and 117 warnings.

Unfortunatly I still cannot identify the problem.

The ICE27 error says:

ICE27 Error 'InstallExecute' Action in InstallExecuteSequence table in wrong place. Current: PostExecution, Correct: Execution http://dartools/iceman/ice27.html InstallExecuteSequence Sequence InstallExecute

I have looked in the InstallExecuteSequence table in the direct editor but cannot see any references to InstallExecute, PostExecution or Execution.

Where do these name come from and how can I trace them back to the executiong sequence?

I was using the Seagate merge modules, so I switched to the InstallShield merge modules but they appear identical. The module names are rdcdesigntime, rdcruntime, reportengine and Seaget registration wizard. Are these the correct modules?

Thanks
Phil.

_doog_
05-26-2004, 06:57 AM
it simply means that:

The InstallExecute action comes between the InstallInitialize action and the InstallFinalize action.

(this is the Execution place)

Philip Mackey
05-26-2004, 10:00 AM
I have tracked down the offending item to the reportengine.msm.

In the ModuleInstallExecuteSequence table the offending InstallExecute is sequence number 4460 and InstallFinalize is sequence number 6600. This validates ok.

In my standard project that uses the merge module the InstallFinalize is sequence number 3150 in the InstallExecuteSequence table.

After building the standard package I open the msi file in the direct editor. In the InstallExecuteSequence table the InstallFinalize is sequence number 3160 and the InstallExecute is sequence number 4460.

What has gone wrong when the merge module is merge into the main project?

How do I fix this?

Phil:confused:

_doog_
05-26-2004, 10:07 AM
Is the InstallExecute action part of your InstallExecuteSequence? if not, insert it before InstallFinalize