PDA

View Full Version : Error 1628!



R-Byter
05-24-2004, 08:25 AM
Please help me! I am a newbie for making installations in installshield. I tried to make simple installation with windows installer but it pops me an error:

Error 1628 - Failed to complete installation!

I have searched over the net for hours and hours and couldnt solve my problem. I followed simple procedure: name and company, added files and folders... When I make release it says that that I dont have any errors and everything is all right, but when i start the installation it informs me about that error. Installation pass well through fisrt steps likie configuring windows installer etc, name and organization, typical instalation and when installation is about to begin, error apear?
What could be the problem? If I asked something that is well known please forgive me. Like I said I am newbie for installshield.
Thanx in advance!

RichAquino
05-24-2004, 03:50 PM
Hi,

This (http://support.installshield.com/kb/view.asp?articleid=Q107319) KB article has some troubleshooting tips for -1628.

Rich

R-Byter
05-25-2004, 02:46 AM
Greetings RichAquino!

I tried all of the possible reasons and none of them seems to be working. I could only post my log file and hope that You will see possible mistake. Dozens of tries for me and nothing. Just to say that before that project I make successfully universal project(with jar archives), but when I tried with so common variant of installation(MSI) I failed.

Looking forward to see Your reply
Thanx in advance

R-Byter
05-25-2004, 03:29 AM
Just tried with 15 files approximately in some test installation and that worked. In my project that didnt worked is more then 7000 files. Are there any limits to number of files?

Thanx in advance!

RichAquino
05-25-2004, 12:14 PM
Hi,

Unless there's one imposed by MSI that I do not know of, there is not a limit to the number of files that your project can contain.

My guess is that something may be going wrong with a file self registering. You could use a process of elimination to determine if that's true.

You may want to try using your script in that simple 15-file setup just to eliminate it as a potential culprit.

Rich

R-Byter
05-26-2004, 02:54 AM
Well, its difficult to eliminite file by file because of number of files. But i eliminate all exe and dlls and nothing. There is just files with uncommon extensions so i guess that is not a problem. Problem could be maybe in paths? I really dont know. I even tried to see if the problem in binary tables(read number of articles about string1033.txt) but everything is ok there.
What are allowed paths(naming conevntions for folders etc...)?
Thanx in advance!

RichAquino
05-26-2004, 09:14 AM
Hi,

Things like this usually come down to the files or the script. You can easily eliminate all files by creating a test release, and deselecting all features. Note that your media must have at least one component and feature, so you'll either want to have one selected, or just add one feature and component (with no files) and keep that selected.

Rich

RichAquino
05-26-2004, 09:20 AM
Hi R-Byter,

Since you posted there, we should handle both similar issues in the other thread...

http://community.installshield.com/showthread.php?s=&threadid=134132&perpage=5&pagenumber=2

Rich